2

I've an ASP.NET website. HTTPS works fine with all browsers (safari, firefox,ie,chromium...) except chrome...

When I want to reach the website on HTTPS with chrome I have "This webpage is not available" and "Establishing secure connection" at the bottom left of the page.

I've test with all my computer at home and work, I've this problem on all computers...

  • Chrome uses the same certificate store as IE, so any problems, likely has nothing to do with the validity of the certificate itself. Chrome and IE trust different types of certificates, tell us about the certificate that might help us, help you. – Ramhound Dec 4 '15 at 18:22
  • Did you try with equivalent versions of Chromium and Chrome? – Daniel B Dec 4 '15 at 18:36
  • If you have access to logs of the Web server - do you see anything about these failed connections? – VL-80 Dec 4 '15 at 18:43
  • use wireshark to help see – barlop Dec 4 '15 at 18:45
1

Check your ASP site and browsers support TLS 1, some software may have dropped support for SSL 2,3 now they are insecure.

For example see howsmyssl.com, poodletest.com, testssl.sh or similar test.

0

Finally we have succeded to resolve this problem.

We have downloaded this tool: https://www.nartac.com/Products/IISCrypto/Download

IIS Crypto is a free tool that gives administrators the ability to enable or disable protocols, ciphers, hashes and key exchange algorithms on Windows Server 2003, 2008 and 2012. It also lets you reorder SSL/TLS cipher suites offered by IIS, implement best practices with a single click and test your website.

And click on the button Best Practises

Now it works on all browsers and we have a A on ssllabs.com!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.