3

Assumptions:

  1. You have a Windows 7 Ultimate as your host.
  2. You have a Linux Kali 2 as a VMWare Workstation virtual machine on this host.
  3. Your network adapter is bridged on the VMWare(Version 10.0.3).
  4. Host IP address = 10.0.0.81
  5. Virtual Machine IP address = 10.0.0.38
  6. Host Gateway = 10.0.0.60
  7. Virtual machine Gateway = 10.0.0.60
  8. Virtual Machine and Host can ping each other and also the gateway successfully.

Problem:

While Host can ping 46.228.47.114 (Yahoo) successfully, the virtual machine can't! In the other words, ICMP requests from host to Yahoo, have ICMP reply packets, but ICMP requests from the virtual machine haven't!

What am I did so far?

  1. I replaced my host IP address with the virtual machine IP address, and vice versa, but nothing changed.
  2. I tried other virtual machines. For all Linux virtual machines I have this issue, while all Windows virtual machines are working fine!
  3. I tried different versions of VMware® Workstation and VMWare VSphere softwares. Issue doesn't solved for my Linux virtual machines.

Differences between ICMP requests:

Windows 7:

enter image description here

Kali Linux: enter image description here

As you see above, there are some difference between requests. Is these difference origin of the problem? If so, how can I handle it?

Note that:

Formerly I even can't ping the Gateway on the Virtual Machine! By sniffing I noticed that MAC address of gateway in the Virtual machine is not correct, so I set it statically with the correct value and after that I pinged it successfully. Now this is the new problem!

Update:

I'm just see that I have Internet access on the virtual machine! I only can't ping it!

Look: enter image description here

Any way I need to see the ping reply packet!

  • this should be tagged vmware and you don't say what vmware software you are using. – gogoud Dec 5 '15 at 8:48
  • @gogoud Thank you. I changed the tags. what vmware software you are using: how many VMWare is there outside? (I even mentioned the version of VMWare). – Abraham Dec 5 '15 at 8:50
  • see vmware.com/products. You mentioned a version number but not the software... – gogoud Dec 5 '15 at 8:52
  • @Archemar Sorry, that was a miswritten. Both are 10.0.0.60. I corrected it. Thanks. – Abraham Dec 5 '15 at 8:56
  • @gogoud Well, I have this problem for both virtual machines installed on VMware® Workstation and VMWare VSphere softwares. – Abraham Dec 5 '15 at 8:59
3
+100

As a workaround (or arguably a fix), disable any network offloading settings on the physical NIC on the host.

  1. Open Control Panel, System, Device Manager
  2. Expand "Network Adapters"
  3. Double-click on your physical NIC to bring up properties.
  4. Select the "Advanced" tab
  5. Disable all properties with "Offload" in the name (varies by network card).

NOTE: You may want to record the initial settings should you want to revert later.

  • What are these offloads for? – Abraham Dec 9 '15 at 5:58
  • Your Wireshark log indicated the header checksum fail may be caused by "TCP checksum offload." Some VMware forums posts indicated that disabling the offloads may be a solution. Did you try it? Did it work? – Steven Dec 10 '15 at 15:57
  • Offloads move stuff that is processed on the CPU for a virtual machine onto the physical NIC, like is done for the host. It helps network performance in super high load situations but is incompatible with many consumer NICs. When having this kind of issue, it's a great thing to try and has personally worked for me a few times. – Arthur Kay Dec 13 '15 at 22:43
1

Try using a static IP address, even if it is static, set a static IP at no-ip.com and then try to ping that IP from both machines. Also see if you can ping the router gateway?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.