0

I am trying to update my mongodb 2.4 to 2.6 but I can't seem to download all the packages. I successfully downloaded all of it before except mongodb-org. I ran yum clean all to clear the cache that might cause the issue. After that, I can't download anything anymore except mongodb-org-server when I tried yum update mongodb-org

Here's a screenshot for your overview: http://prntscr.com/9aeusp

Error Downloading Packages:
  mongodb-org-shell-2.6.11-1.i686: failure: RPMS/mongodb-org-shell-2.6.11-1.i686.rpm from mongodb: [Errno 256] No more mirrors to try.
  mongodb-org-tools-2.6.11-1.i686: failure: RPMS/mongodb-org-tools-2.6.11-1.i686.rpm from mongodb: [Errno 256] No more mirrors to try.
  mongodb-org-2.6.11-1.i686: failure: RPMS/mongodb-org-2.6.11-1.i686.rpm from mongodb: [Errno 256] No more mirrors to try.
  mongodb-org-mongos-2.6.11-1.i686: failure: RPMS/mongodb-org-mongos-2.6.11-1.i686.rpm from mongodb: [Errno 256] No more mirrors to try.

I tried accessing the url's in the browser and I successfully downloaded the rpm files. What do you guys think is causing the issue?

Here is my /etc/yum.repos.d/mongodb.repo in case you might ask.

name=MongoDB Repository
baseurl=http://downloads-distro.mongodb.org/repo/redhat/os/i686/
gpgcheck=0
enabled=1

Update:

Today I successfully downloaded all the dependencies except for the last one (as seen in the screenshot). You will notice that only mongodb-org is not highlighted; Hinting that it is not yet downloaded.

http://prntscr.com/9aiwka

I am pretty sure that yum does not use any proxies as what @kubanczyk says. I haven't configured anything like that before (unless there is a proxy set by default after a fresh install).

Just to let you know. I am running centos 6.6 on Virtualbox 5.0.10 r104061 under Ubuntu. The network settings are Bridged Adapter (Intel PRO/100 MT Desktop 82540EM). The virtual machine has a static ip set with the following network script.

DEVICE=eth0
HWADDR=08:00:27:AC:A0:96
TYPE=Ethernet
UUID=72a2164a-7344-47dc-ad75-89822dbf6002
ONBOOT=yes
NM_CONTROLLED=yes
BOOTPROTO=none
IPADDR=192.168.1.109
NAME="Sys Eth0"
IPV6INIT=no
2
  • Check your Internet connection. Dec 4 '15 at 21:58
  • the vm im running can successfully ping and download files from the internet Dec 4 '15 at 22:09
0

This looks like a proxy issue to me. The browser you use on the same box has a proxy configured differently than yum's own proxy. For example, maybe yum has some incorrect old proxy and browser works great with no proxy at all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.