12

I am running Windows 10 under VMWare Workstation Player 12.0.1 (Windows 10 is the guest, Ubuntu 15.10 is the host). When I run task-manager, it always shows that the cpu utilization is 0%, regardless of what the computer is actually doing. Each process in Task Manager also displays 0% CPU usage (even when building a large project under Visual Studio).

However, when I run "resource monitor", it clearly shows that there are processes that use much more than 0%.

Edit Here are some screenshots, as requested: Task manager performance tab Task manager processes Resource monitor

  • Can you include links to screen shots of the task manager? Also, it's a bit unclear where you are running task manager (in the host? in the guest?) and precisely what you're seeing. – David Schwartz Dec 5 '15 at 11:42
  • I updated the question according to your comment. – Alex Shtof Dec 5 '15 at 16:59
  • have activated the option to visualize Perf counters in the VM options? if not, do so. – magicandre1981 Dec 5 '15 at 19:08
  • @Alex, anything new about this? I have exactly the same issue. – Arin Ghazarian Jan 5 '16 at 4:34
8

Uninstalling Hyper-V, which windows installed by default for some reason, solved this problem and many other problems I had with my virtual machine.

It can be uninstalled using the following steps: 1. Go to Control Panel --> Programs and Features 2. On the right side of the window, click on Turn Windows features on or off. A dialog box should open 3. Uncheck Hyper-V in the dialog box above and click OK

  • This is occurring on my Windows 10 Enterprise VM even though Hyper-V is not installed. Strangely it happened after I installed the Nvidia 368.81 drivers for my dual GeForce 980s. – Matt Aug 8 '16 at 23:25
  • 2
    That's unfortunate as Docker for Windows requires Hyper-V as far as I know. There's other things that require it as well, such as the Windows Phone emulators in the SDK. – jocull Jan 12 '17 at 12:57
3

Your pictures looked exactly like mine, 0% CPU usage in Task Manager and Resource Monitor shows the CPU is always on max frequency. It was due to Hyper-V was installed in my VM. After uninstalling it, CPU usage display went back to normal. I didn't need Hyper-V in my VM so that was fine for me. I would like to know if there is another solution.

  • Please see my answer. I found a way to fix the problem. – Alex Shtof Jun 5 '16 at 11:46
0

Uninstalling Hyper-V didn't work for me. I did the following:

  • Shut down VM
  • In the .vmx file, changed the following line:

    hypervisor.cpuid.v0 = "FALSE"
    

    to

    hypervisor.cpuid.v0 = "TRUE"
    
  • Restart VM

After that the CPU showed activity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.