2

I have Windows 8 on my laptop and the jumplist for putty has always worked just fine. After installing Putty on my desktop (Win 10) the jumplists do not show up when I right-click the taskbar icon, Putty v0.65.

After scouring the internet, apparently a fix was provided in version 0.66. So I uninstalled 0.65 and installed 0.66... no help, same issue. some comments on a similar question to this actually said they had better luck with the development version, so I uninstalled 0.66 and installed the 11/30/2015 version of Putty. I have unpinned and re-pinned as well as deleted my saved sessions and recreated them. I even tried to clean registry entrys with ccleaner after uninstalling and before installing. I currently have 2 saved sessions and this is what my right-click taskbar context menu looks like (start menu jump list is exactly the same):

enter image description here

P.S. I have visited this question and tried it's solutions. However, I was not able to comment due to my limited reputation, so I had to create my own question.

  • This seems to be fixed (for me, at least, on Windows 10) as of version 0.67, for anyone visiting this question now. – maxton Mar 23 '16 at 22:18
  • After recently upgrading my laptop to Windows 10, the jumplist remained working. For the desktop, I'm thinking that I may have some OS level issue preventing the newer versions from fixing it. – codenaugh Apr 9 '16 at 17:22
  • I know this is an old question, but wanted to point this out for anyone who winds up here scratching their head: be sure to have "Show recently opened items in Jump Lists on Start or the taskbar" enabled under Personalization > Start in your Windows 10 settings. I turned it off after doing a fresh Windows install and didn't think anything of it until I wasn't seeing my recent sessions. – Brian Poole Jan 30 at 18:00
3

Proposed solutions that I have seen have not worked for me. But this does work:

Assuming that you already have PuTTY pinned to the taskbar:

  1. Start a PuTTY session.
  2. You will now have a second PuTTY icon on your taskbar. Unpin the original one.
  3. On the new icon, right click and chose Pin to taskbar. Jump lists will be there on this new icon.

In case it matters, I am running PuTTY 0.68, 64-bit.

  • This didnt actually create a new Putty icon on the taskbar. There was a single Putty icon with 2 windows attached to the same icon – alpha_989 Mar 6 '18 at 13:52
  • That worked for me too, perfect! Version 7.0.... Thank you! Been annoyed about this for several days ;) – WoodyDRN Apr 19 '18 at 7:24
1

If you find yourself in the same boat as me, you can use the following workaround that I found here:

http://www.thegeekstuff.com/2009/07/10-practical-putty-tips-and-tricks-you-probably-didnt-know/.

  • Create a new PuTTY windows shortcut
  • Rename this shortcut to your favorite name.
    • example: dev-db.
  • Right-click on this shortcut and select properties.
  • In the Target field, at the end append “-load putty-session-name”
    • example: "C:\Program Files (x86)\PuTTY\putty.exe" -load dev-db
  • Right-click the shortcut again and choose "Pin to Taskbar"
  • You can now delete or move the shortcut, if you wish

This will be an additional putty taskbar item if you already had the standard putty pinned to taskbar. Since I only use one putty session every time, I deleted the original putty taskbar pin. If you have multiple connections you want to pin, then you would repeat the above steps for each one and would probably want to change the shortcut icons for each to differentiate.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.