0

My location is French Swiss, but I want my Windows 10 computer to work in English language and have configured it that way.

I have configured:

  • ENG English (United States) with Swiss French keyboard as default

And the following other optional language / keyboard pairs with Numlock ON with all configurations

  • DEU German (Switzerland) with Swiss French keyboard
  • FRA French (Switzerland) with Swiss French keyboard
  • ITA Italian (Switzerland) with Swiss French keyboard

Before login in I have only the following options, none of which I had installed and has Numlock OFF:

  • FRA French (France) with French Keyboard
  • ENG English (United States) with US Keyboard

Since the physical keyboard of my computer is Swiss French it is quite disagreeable to enter my password, typing blindly. After login the language / keyboard combination appear and work correctly, but the weekday names appear in French (jeudi instead of Thursday, etc.) although everything else is in English.


My questions:

  1. How can I configure the language/keyboard combination to appear correctly before login?
  2. How can I have the weekday names in English and not in French after login?

1 Answer 1

2

The keyboard layout that is used when you log on to the computer is read from the registry under:

HKEY_USERS\\.DEFAULT\Keyboard Layout\Preload

If you delete all entries except the first one and make sure that the first and only entry is set to 0000100c, which is the code for the Swiss French keyboard, your login shall work with that keyboard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.