0

I have a laptop. Formerly, it had only Windows installed (all worked fine). Then I formated the PC and now I dual boot Ubuntu 14.04.3 with Windows 10, and now I have a problem with wifi in Windows:

If I'm very, very close to the router (less than 2 meters of the router), wifi works well in both system.

But if I'm at more than about 4 meters from the router, wifi only works well in Ubuntu. In Windows, the wireless network looks available but when I try to connect, it doesn't reach connection.

That is, since I formated the PC, in Windows I have a ridiculously low wifi signal reception.

I tried installing all oficials drivers that I found, but it didn't fix it. The weird thing of all this, is that Ubuntu doesn't require me to manually install any additional wifi driver, and it works like a charm. On the other side, Windows requires the installations of officials drivers, that doesn't even work in my case.

Thing that I know/suspect:

  1. This is a software/driver problem, not a hardware (wifi card) problem, cause before I formated the PC, this didn't happen (and in Ubuntu the wifi card still works well).
  2. This isn't a Windows 10 problem, cause I tried Windows 8, and 7, and I have the same problem.
  3. This isn't a router/AP problem, cause it happens with other wifi networks too.

So, what can I do? Is there a way to extrapolate the wifi driver/configuration of Ubuntu to Windows?

By the way, the wifi card is

  • product: AR9462 Wireless Network Adapter
  • vendor: Qualcomm Atheros
  • What wireless driver are you using? – qasdfdsaq Dec 6 '15 at 23:47
  • I've tried all drivers I found, including Windows generic drivers, and the official Atheros driver (tried many versions, currently using 10.0.0.318) – user246185 Dec 7 '15 at 1:37
  • In Ubuntu I'm using: driver=ath9k driverversion=3.19.0-39-generic – user246185 Dec 7 '15 at 1:41
  • If you have wifi encryption on, turn it off and see if it makes a difference. Also what is the model of the AP? – GeekyDaddy Dec 7 '15 at 3:12
  • Hi, the router is Motorola SBG901. I've tried turning off the encryption, but it didn't make any difference. – user246185 Dec 7 '15 at 16:08
0

Try opening the Power Options in Control Panel.

Chose to edit a Power Profile. There is an option that says "Wireless Adapter Power Savings". Turn it off. Report back with your findings.

PS: Does connecting your Laptop to a power supply help?

  • Hi, thanks for your suggestion. I tried it, but it didn't make any difference. Neither connecting it to the power supply. – user246185 Dec 6 '15 at 23:29
  • I'll look into any more possibilities. – Ashhar Hasan Dec 6 '15 at 23:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.