6

I'm trying to mount a Windows 10 partition on Fedora 23, with read-write permitions (but the same problem occurs on Linux Mint 17.3 and Ubuntu 15.10), but everytime I get this message:

$ sudo mount /media/windows
Windows is hibernated, refused to mount.
Failed to mount '/dev/sda2': Operação não permitida
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

This is how my /etc/fstab file looks like:

#
# /etc/fstab
# Created by anaconda on Fri Dec  4 18:50:21 2015
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=b9fe99a1-3a93-4cca-8fa1-0ab62fb8d134 /                       ext4    defaults        1 1
UUID=6E0C67260C66E913   /media/windows          ntfs    default,rwx      0 0
UUID=2E0A29CB533416A0   /media/finger           ntfs    default,rwx     0 0

Now, I know there are a lot of questions around Superuser, Ask Ubuntu and other SE variants about the same subject, but there's a difference here:

I have already disabled the fast startup "feature" from Windows 10, avoiding the partial hibernation, have properly shut it down and restarted, but the partition is still locked in hibernation. This problem persists through every Linux distribution, they can't mount the Windows partition.

What should I do to fix this problem?

EDIT:

I want to be able to put Windows 10 in hibernation mode when I want to. I don't want to completely disable hibernation. I was always able to do so on Windows 7, so what changed on Windows 10 that the partition is always in hibernation lock after a full shutdown without fast startup?

5
  • Possible duplicate of dual boot ubuntu with windows 8
    – Ramhound
    Commented Dec 7, 2015 at 12:29
  • 1
    @Ramhound no as I wrote before it was marked: "I have already disabled the fast startup feature from Windows 10". The problem is different. Commented Dec 7, 2015 at 13:23
  • You are welcome to disagree with my suggestion it is a duplicate, does not mean, it isn't one. Here is another one. here is a specific Windows 10 duplicate. here is another one. Here is an alternative
    – Ramhound
    Commented Dec 7, 2015 at 13:31
  • 2
    @Ramhound The question you linked as this being duplicated of if not a duplicate. It is about something else. The other two alternatives are also about something else. The 3rd one is actually helpful. The last one also doesn't answer the question as I know how to disable the fast startup - As I said in the question, it already was disabled. Commented Dec 8, 2015 at 11:03
  • Hibernation isn't disabled though
    – Ramhound
    Commented Dec 8, 2015 at 11:17

2 Answers 2

3

Disable hibernate by powercfg -hibernate off
For details, see http://www.tenforums.com/tutorials/2859-hibernate-enable-disable-windows-10-a.html

7
  • I didn't want to turn off hibernation mode completely as I find it useful when the computer is running out of battery. This might be the only solution though. Commented Dec 7, 2015 at 10:49
  • The warning message speaks for it self. "Please resume and shutdown Windows fully (no hibernation or fast restarting), or mount the volume read-only with the 'ro' mount option.". You need to make sure neither of those conditions are true to avoid this warning message.. The reason the warning is not an "and" statement is because only certain versions of Windows supports "fast restarting"
    – Ramhound
    Commented Dec 7, 2015 at 12:27
  • 1
    Fast Startup in Windows cannot work without hibernation. Commented Dec 7, 2015 at 12:50
  • @BrunoFinger just as a temporary test, does disabling hibernation work? Maybe windows 10 is just ultra-stubborn and always "dirties" it's filesystem when hibernation is even enabled, though not used?
    – Xen2050
    Commented Dec 11, 2015 at 10:19
  • Disabling hibernation works in my Windows 10. Commented Dec 11, 2015 at 14:27
0

itimees gave me the hint I needed:

Hold the Shift key down while selecting Shutdown from the Windows Login power menu option.


#Ignorable_Background

My task was to reset a lost password on a Windows computer. I could boot to Linux from a USB, but the Windows, NTFS volume would only mount in read-only as version 10 of Windows usually hibernates on shutdown. This prevented me from clearing the user's password in the read-only SAM file.

Since I didn't have the password, I could not use the other answers here to clear the hibernation file or turn off hibernation upon shutdown, ...

Another post recommended sudo ntfs-3g -o remove_hiberfile /dev/sdXN /path/to/mount, run from the Linux terminal, but this did not work since the Windows Volume could only be mounted in read-only mode, no file changes could be made.

itimees' hint (above) let me know that I could hold the Shift key down on the Windows computer when I Shutdown from the power menu option on the Windows Login screen. This then performed the needed full (no hibernation) shutdown. The Windows Volume was then able to mount in read‑write mode from the Linux boot and the user's password was then able to be cleared.

1
  • 1
    As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Mar 7, 2023 at 18:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .