15

I have the Slack Windows app on my Windows 10 machine. I noticed that the notifications don't work properly. In 'Preferences', I click 'Send test notification', but it doesn't send one. When I had Windows 8.1 it wasn't working neither. How can this be fixed?

Thanks in advance.

  • 3
    What I've noticed is that the notifications are being sent, but they appear below all other windows. The solution is to either restart slack or to minimize to desktop, send a test notification and then click on it. – h2ooooooo Aug 3 '16 at 12:31
  • FWIW I have the same problem and I'm just using the web based app for now. – slim Aug 8 '16 at 14:17
  • Also, try this: betanews.com/2015/09/09/… – slim Aug 8 '16 at 14:17
  • Are you using the 64-bit version of the desktop app? Does the 32-bit version work for you? I've seen it not be a problem for Windows 7, but Windows 8/10 64-bit version has spotty notification sounds while the 32-bit version works fine in Windows 8/10. – BrionS Sep 22 '16 at 20:59
8

Have you tried closing and reopening Slack app after checking Notifications >> Send notifications for: >> All activity?

It worked for me and my colleagues.

  • 5
    Restarting the app worked for me as well. – IDSPISPOPD Mar 10 '16 at 14:20
  • 2
    Worked for me on Windows 7. Good old "Have you tried turning it off and on again?"! – Matt Jul 12 '16 at 19:49
5

Neither of the answers/comments worked for me. Will share what helped in my case (Windows 10 x64). Might help anyone else. I had to turn off Slack's integration with Windows Action Center basically and they started to show up.

Solution:

  1. Press: Win + R
  2. Type: "slack://notReallyWindows10"
  3. Hit: Enter

PS, I think I did this twice.

3

I had quiet hours turned on in Windows. Turning it off fixed Slack's notifications. Quiet hours are only supposed to take effect from 12AM to 6AM, so I'm not sure if this is a Slack problem or Windows problem.

  • 1
    This was my issue 100%, I was pulling my hair out – meanbunny Sep 27 '17 at 17:40
3

I had this same issue. I tried the solutions listed here and it still didn't work. I ended up going into Windows Action Center settings and switched #slack notifications off, then back on and it worked fine.

1

None of the solutions here worked for me. What finally did work, was going to Help > Reset App Data

0

I had some snooze notifications turned on in Slack (a bell-symbol). Turning it off worked for me... It is supposed to be turned on automatically after office hours but Slack seemed to fail in puting me in the right time zone.

0

I tried everything here and nothing worked Also, Slack was not in Notifications & actions settings

In the end I uninstalled Slack completely, then reinstalled Slack from the Microsoft Store. After that I could see Slack in Notifications & actions settings and Action Center notifications worked again.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.