3

I run Arch Linux with a "normal" Xorg desktop, that is, using LightDM as login manager and the i3 Window Manager (with some components from Xfce, GNOME and KDE as needed). The graphics is the integrated Intel graphics from my i7-4770T processor.

Since some time ago, it happens that whenever I press Alt+Left or Alt+Right or any of the Alt+F1..F10 key combinations, the screen flickers shortly. The action I wanted to do (e.g. go back in the browser history) is executed, but the screen flickers.

I have a suspicion that the kernel key bindings for changing the VT are executed, i.e. the VT changes, Xorg is notified and will display on the new VT.

I have tried adding

Option "DontVTSwitch" "true"

and

Option "XKbOptions" "srvrkeys:none"

to my xorg.conf in the appropriate places, and I can see them being accepted, but neither changes the describes behaviour.

  • My suspicion is that this has something to do with the desktop switcher. Check if it's enabled on your setup, and see also this thread (although for Ubuntu). – harrymc Dec 9 '15 at 16:14
  • What is a desktop switcher? I don't have compiz or similar installed. – Stefan Seidel Dec 10 '15 at 22:31
  • I'm not using i3, but it seems according to the User's Guide that the $mod+arrow keys are used for changing the focus. You might need to disable these key combinations. – harrymc Dec 11 '15 at 8:40
  • Thanks, but my $mod is the Windows key (mod4), not Alt. – Stefan Seidel Dec 11 '15 at 9:33
  • 1
    You might consider adding some more information about your setup to the post. – harrymc Dec 11 '15 at 9:51
1

Ok, as it was the same case here and here, after several months of this annoyance, the latest system upgrade fixed it (I upgrade every couple of days, so it must have been a recent fix). Whatever it was causing it, it is gone now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.