1

I'm trying to connect an older phone to my PC, but it keeps assuming it should use drivers for a different model of that phone. I need to forcibly remove the phone's driver from Windows 7 as my device keeps installing incorrectly. Uninstalling it in the Device Manager and then "Have Disk' installation of the right driver doesn't help.

I find the name of the offending driver by running:

pnputil -e

However, when I try to remove it with:

pnputil -d oemXX.inf

One of the offenders says:

Deleting the driver package failed :The specified file is not an installed OEM INF.

Why does the system claim that the file is not an installed OEM INF even though I got its name from the system itself? Is there any way I can get rid of the offending driver?

  • 1
    If you decide to vote my question down please let me know what's wrong with it so I can improve for the future. I can't immediately see anything wrong with it. The title explains clearly my problem. In the body I provide the background and the ways in which I tried to approach it. The subject matter of the question - I wasn't able to find any other questions asking the same thing, and I feel it is quite general in nature, potentially helpful to anyone. – Sanuuu Dec 7 '15 at 15:25
  • 1
    I didn't downvote, but there are two huge problems with your question: 1) You don't tell us what problem you're trying to solve. You say "my device keeps installing incorrectly" but don't tell us what device or in what way it's incorrect. 2) You don't explain why you're using pnputil rather than the more conventional ways of removing drivers. Did those not work? If so, what happened when you tried? – David Schwartz Dec 7 '15 at 15:38
  • 1) I'm trying to connect an older phone to my PC but it keeps assuming it should use drivers for a different model of that phone. I didn't think that context provided very much useful information. 2) I did say I used more conventional ways of removing the driver. It's right there in the first sentence's parenthesis. – Sanuuu Dec 7 '15 at 15:43
1

You picked the wrong OEM.inf. If the command line tool is too complicated or you, try the tool DriverStore Explorer [RAPR].

enter image description here

Run it, click on enumerate to get a list of all installed drivers. Now select the "bad" driver and click on Delete Package.

-1

Try running a registry cleaner like CCleaner in order to make sure there are no zombie driver entries in the registry.

If there are, remove them and reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.