20

I use Powerpoint 2010 on Windows 7. My keyboard layout is German, but I write my presentations in English.

Now I created a presentation with Default Language set to English, and I want it to use English for proofing. When I create a new slide/textbox/... the language is indeed English. However as soon as I start typing, the language changes to German. This happens because my system-wide keyboard layout is set to German. If keyboard layout is changed to English, everything is alright.

Now I want to stop Powerpoint from changing its proofing language to match my keyboard language. I tried changing the LangTuneUp key to Off or Prohibited in HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\LanguageResourcesas indicated here, but it didn't help. Any other ideas?

P.S. Oh how I hate it when application-developers try to be clever.

1
  • I'm grateful for this question, as I did not realize, that the problems I had with the proofing language in PowerPoint were driven by the keyboard language. Knowing that, I can switch my keyboard to English, when I work with PowerPoint and use this as a cumbersome workaround.
    – Hilarion
    Oct 16, 2020 at 15:19

2 Answers 2

10

To disable Powerpoint from matching the system language (which fixes this very annoying behavior), go to Options->Language, then under Choose Display and Help Languages move "Match Microsoft Windows" and "Match Display Language" to the bottom of the list.

3
  • 3
    Any update for Windows 10 + PowerPoint 2016? What if the new default for Display and Help Languages is the same as the Windows Language?
    – reschu
    Feb 13, 2019 at 11:01
  • 3
    This solution does not seem to work for me. I had it pretty low already and moving it to the end (and restating the application) did not resolve the problem.
    – Hilarion
    Oct 16, 2020 at 15:17
  • This answer is not correct! Changing display language has nothing to do with the proofing language. PowerPoint is matching slide's language (proofing language) with your current keyboard layout and that is what you must change. See my answer below.
    – trejder
    Jun 19 at 15:00
0

I found the given answer to be incorrect. In my case to solve this problem I had to change current keyboard layout to the language that I want to use in PowerPoint.

This could be achieve temporarily, by pressing Win+Space that many times until selected keyboard layout matches your desired proofing language:

enter image description here

After that PowerPoint will auto-match proofing language to your selected keyboard layout.

You may try to force-set this permanently, by changing selection Use language list (recommended) to your desired language in Time & language → Typing → Advanced keyboard settings:

enter image description here

But I found this not permanent / not working at all and must use first solution each time I use PowerPoint.

Source: Prevent PowerPoint from auto-changing typing language.

Not the answer you're looking for? Browse other questions tagged or ask your own question.