My internal drives are showing for some reason as removable in windows (one is SSD and the other is an HDD) in Windows 10 Pro.

I read somewhere this can affect performance.

Why is this? Is this defined in the BIOS or in Windows?

Is it possible to fix this?

This is NOT the same as How can I remove the option to eject SATA drives from the Windows 7 tray icon? since that question is for Windows 7 and the solution provided does NOT work for Windows 10.

  • 3
    Possible duplicate of How can I remove the option to eject SATA drives from the Windows 7 tray icon?. As far as I know, all SATA drives are, technically hot-swappable given the right conditions. I am skeptical about performance degredation
    – Yorik
    Dec 8, 2015 at 21:19
  • @Yorik that question was asked regarding Windows 7, but I will try the same solution for Windows 10 and see if it works. I'm not sure what I should do if it works for Windows 10 as well though... delete the question?
    – traveh
    Dec 9, 2015 at 3:03
  • I'd recommend you to re-install the SATA controller drivers for your computer from the motherboard manufacturer's website, @traveh! It's possible that Windows Updates could have messed things up for you and that's why the HDDs are recognized as removable media. I'd also check if you've got Write caching enabled in Device Manager's properties. I'd also go to BIOS and make sure you have 'Hot Plug' disabled. Some mobos that allow such modifications could cause the SATA drives to show in the 'Safely Remove' if 'Hot Plug' is enabled. Hope this helps. Keep us posted. :) Dec 10, 2015 at 11:06
  • +1 for the 'Hot Plug' theory. I just tested that in my UEFI setting. Enabling it makes my drive removable and disabling makes it non-removable. I am using the 'Standard SATA AHCI Controller' driver (storahci.sys) from Microsoft in Windows 10. SATA controller mode in UEFI setting is 'AHCI'.
    – Tom Yan
    Feb 13, 2016 at 12:12
  • I had the same problem and this one worked for me superuser.com/a/961242/523387
    – Mя. AMiNE
    Jun 25, 2017 at 23:15

7 Answers 7


The issue lies in your BIOS, and has little to nothing to do with Windows. Check if you can manage your SATA devices, and Disable the Hot Plug function.

  • 2
    Well, Windows is just faithfully following what the hardware is reporting. But the issue can be fixed at either point (override in BIOS, or in Windows).
    – Xan
    Apr 18, 2019 at 8:58
  • 1
    This answer is best because it actually explains why this is happening, and presents a very easy fix. It worked for me and I'm glad I read this answer before messing with registry modifications. Jul 26, 2020 at 21:18
  • In a server environment hot swap may be useful but the casual home PC user rarely opens his case and swaps SATA hard drives on a running system. Upvote...
    – yoyoma2
    Sep 13, 2020 at 5:35

As long as you use the microsoft AHCI driver: Check the properies of the drive in the device manager, note the "bus number". If it is Bus 0 it is this registry key for Win8/Win10:

reg.exe add "HKLM\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device" /f /v TreatAsInternalPort /t REG_MULTI_SZ /d 0

If it is Bus 0,1,2,3,4 and 5 use this:

reg.exe add "HKLM\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device" /f /v TreatAsInternalPort /t REG_MULTI_SZ /d 0\01\02\03\04\05


Source: https://support.microsoft.com/en-us/help/3083627/internal-sata-drives-show-up-as-removeable-media

  • This does work for multiple drives too, but it wasn't initially clear to me. To clarify, the registry entry value should end up a multi-line string with each Bus number in a column. For more info see: tenforums.com/drivers-hardware/…
    – Chris
    Sep 10, 2018 at 9:43
  • 3
    I'd like to point out that the reboot part is important (and is not mentioned in the Microsoft support article)
    – comecme
    Apr 16, 2020 at 14:26
  • This worked great for me on an older non-uefi bios with ahci but no options for hot plug
    – Smock
    May 12, 2021 at 22:27

I had the same problem with a Gigabyte P55-UD5 mainboard. With the default MS driver some internal drives showed as removable.

Because the drivers on Gigabyte's site were very old I used this post to find the newest one (in my case: 64bit Intel RST(e) AHCI/RAID Drivers v12.9.4.1000) and installed it via Device Manager, update driver.

  • In my case I downloaded and installed the Intel SATA/RAID driver (aka Intel Rapid Storage Technology) from Gigabyte (yes, the ancient drivers) and it worked well.
    – Sam Sirry
    Aug 10, 2019 at 2:57

Check Control Panel --> Device Manager --> Disks --> double click on the disk drives and make sure that under Policies tab drive 'write cache' is enabled and there is no 'optimize for quick removal' enabled. This is directly related with how windows considered or not a drive being removable.

Also, update to the latest chipset and AHCI/RAID driver.

  • 2
    This was copy/pasted from an Ease-US article and is not helpful.
    – Alain
    Oct 14, 2018 at 18:20
  • No, it's SOP in such a case.
    – Overmind
    Oct 15, 2018 at 7:21

Tip for Windows 10 users: create a 'Storage Pool' through 'Storage Spaces'. A Pool can exist of just 1 storage medium. That will integrate the removable storage to be seen as an internal drive.

It's not a solution for your system drive. For that the best bet is to find the most recent driver.If that does not work for you might want to change your 3rd party AHCI/RAID controller driver to the 'Generic SATA AHCI controller' that was shipped with Windows.

In my case I had disks attached to a Marvell adapter show up like that. After changing them to create an MS storage space instead of a Marvell mirrored drive they appeared in the normal spot thus making them available to disk optimization too.

  • I landed here precisely because a Storage Spaces pool I'd constructed from two 2TB HDDs is being reported as removable. I'm trying to enable the Windows 10 image backup in Control Panel, and it refuses to use my pool. Jun 13, 2019 at 21:12

I did all the above and my system still thought my two hard drives were removable drives but I did the following and It fixed the problem. Check Control Panel --> Device Manager --> Disks -->right click on the drive in question and select properties --> then select Volumes --> populate... this will identify the drive as a hard drive. Once done, reboot . All fixed.

  • 2
    This didn't work for me.
    – Sam Sirry
    Aug 10, 2019 at 2:53
  • 1
    It was your reboot that fixed it after you followed other advice above. Clicking on populate volumes i purely informational.
    – BenH
    May 5, 2020 at 14:03

This is generic problem of windows 64 bit versions. Microsoft has yet to find and fix the issue. It is related to performance. 64 bit operations cannot cope up so 64bit os is patched to treat internal drive as portable removable drive. Install 32bit version of windows, this issue is not there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .