14

Problem

After updating my graphics driver to the latest version from NVIDIA (downloaded direct, not using Windows Update), my third monitor which is an Acer V226WL is not displaying the proper and native resolution. The native resolution is 1680 x 1050. I have a GeForce 660, and have had no problems until now with my monitors. The monitor is connected via DVI.

Incorrect resolution:

What I have tried:

  • The Custom Resolution Utility
  • A monitor driver from Acer
  • Was going to add the resolution to the registry, but saw it was already there
  • A different DVI cable
  • Disconnecting a monitor / messing with combinations of the connections
  • Putting the monitor on another Windows 10 machine of mine that has identical NVIDIA display drivers
  • Tried using Driver Sweeper
  • Took a look at this question which seems severely outdated. I see no option in the NVIDIA Control Panel to add a custom resolution. Only NVIDIA official article about adding custom resolutions is from 2006.. After using Driver Sweeper, I am now able to define custom resolutions when I wasn't able to before. However:

Custom resolution using the NVIDIA Control Panel:

Trying the Custom Resolution Utility:

I setup the resolution to be 1680 x 1050 yet, take notice that the format is almost 4:3 with black vertical bars on the left and right. It's hard to distinguish in the picture. I added in semi-transparent red lines to show approximately where the monitor edge is, not sure if this is helpful but figured I should. Here is the original image, if you want.


Does anyone have any suggestions as to why this is happening, or how I can troubleshoot it? Like I said, it was fine before the driver update.

  • Have you checked the maximum bandwidth of the graphics card. There's only so much data which it can get out of its RAM in the time required to pump the data to the monitors. The more monitors you connect, the higher the required memory bandwidth. You can lower the resolution of another monitor or reduce colour depth to see whether it makes a difference. – Run CMD Dec 10 '15 at 7:40
  • @ClassStacker Disconnected one of my monitors, nothing changed. Lowered resolution of other monitors also, nothing changed. Also, here are the GTX 660 specifications. I have 2GB VRAM and 144.2GB/sec Memory Bandwidth. I feel like if that was the issue, I wouldn't be able to play A-List games on high settings without noticing issues. – Insane Dec 10 '15 at 19:13
  • Having this same problem with a AMD Radeon R5 240 in a Dell Optiplex 7020 and a Dell Ultrasharp U2410 monitor. Only one monitor hooked up. Going to try other cables and see what happens. – HK1 Aug 15 '16 at 14:32

12 Answers 12

8

In my case, the monitor itself needed to 'reboot'. Disconnect the monitor from the mains power and disconnect the display cable from the back of the pc/laptop. Wait about 30 seconds. Reconnect the mains power to the monitor. Reconnect the display cable to the pc/laptop. That fixed it for me.

  • I was having the OP's problem with my U3415W and this fixed it. – labreuer Jan 19 '18 at 14:15
  • Surprisingly, this also fixed it for me on an EliteDisplay E231 – SPQR Oct 30 '18 at 11:38
  • it fixed the problem also on my samsung syncmaster ta350 – Antonio Feb 11 at 8:11
  • Physically, disconnecting and Reconnecting HDMI cable causes wear and tear. It is it possible simulate disconnection through code or device manager? – PAS Apr 14 at 19:40
  • Lots of new TVs just hibernate and don't turn off, so this is 100% necessary. I had to unplug the power cable to reboot the screen, then it worked fine. – GuidedHacking Jun 27 at 1:37
1

I would test combinations of monitors. I've never seen it with nVidia cards, but internal graphics like intel sometimes limit the resolution as more monitors are attached, or prevent you from having three monitors at all. There's also a chance that a cable could be damaged between the card and the monitor. Like I said, try combinations to see if it's having three monitors that causes the problem or it's the specific monitor. If it's the latter case, I would suspect that either the cable is damaged or the monitor is not properly identifying to the card.

That would explain how in the first screenshot you posted it shows "didn't detect another display."

  • No, it said "didn't detect another display" because I clicked "detect" and since I don't have 4 monitors nothing else was there to detect. I will be playing around with combinations when I'm home, but I do want to point out I used a brand new DVI cable and the same thing is happening. And also, of course, the GTX 660 supports up to 4 displays. – Insane Dec 10 '15 at 6:05
  • 1
    That's what I figured. I didn't think nVidia supported anything less than 3 displays. Again, it could be the fault of the monitor. Report back after the tests and we can continue from there. – Patrick Dec 10 '15 at 6:06
  • The only reason I'm doubtful it's the monitor is because it was fine just before a driver update, but we'll see. – Insane Dec 10 '15 at 6:07
  • And the 660 certainly supports that resolution too. I used to drive a 4k display off one. Hm. Monitor drivers? – Journeyman Geek Dec 10 '15 at 8:27
  • @JourneymanGeek Yes it does and it's funny because I didn't need monitor drivers before and I have 2 more of those exact type of monitors used on a different system. Plus Acer doesn't have any past Windows 8, and the ones for Windows 8 which I tried didn't make any difference at all. – Insane Dec 10 '15 at 19:02
1

Getting back at you, following the comment you posted. As I read it, you're looking into Windows 10's native screen resolution settings, not GeForce settings.

What I would do:

  1. Sweep all graphical drivers with Driver Sweeper
  • Use the official uninstaller(s) of the driver(s) you want to uninstall.
  • Reboot your PC in Safe Mode. Run Driver Sweeper and select what to clean.
  • Analyse lists all the entries possible to remove, cleaning removes the entries selected.
  • More drivers can be selected for the same cleaning process.
  1. Better safe than sorry: get rid of any registry entries of drivers or manufacturer software, I personally use Ccleaner (the free version is sufficient). [Possibly not necessary as Driver Sweeper already seems to take care of this.]

  2. Now, download GeForce Experience. I'm not sure if the programme will automatically install drivers for you as well, but nonetheless, you can update your drivers from within the programme. You can find the GeForce Experience icon in the Windows tray at the right corner of the screen. Right click and Check for updates.

  3. If all updates are installed, reboot you system. [Possibly not necessary.]

  4. Right click the icon again, and select Open NVIDIA control panel (or something similar). You'll get the good ol' NVIDIA control panel, as the image below shows. Here you should find options and ways to more precisely adjust your screen resolution.

NVIDIA

  1. After you got everything working, you can go ahead and remove Ccleaner and Driver Sweeper. We don't want any residual waste to be left behind!
  • Resolution settings are identical in NVIDIA control panel as they are in Windows. Changing it one place changes it the other place. However it can't hurt to try driver sweeper. – Insane Dec 10 '15 at 13:55
  • @Insane And what happens when you define a custom resolution in NVIDIA control panel for that screen. See the screencaps in this post. – Bram Vanroy Dec 10 '15 at 19:14
  • I used Driver Sweeper as you said, nothing changed. However before, I couldn't set custom resolutions. The button was greyed out. Now however, it is not greyed out (after using driver sweeper). – Insane Dec 10 '15 at 19:17
  • Still doesn't work. I tried automatic timing and GTF as you said in the old question. Neither worked. – Insane Dec 10 '15 at 19:18
1

Some people reported display port cables causing issues so I changed my display port cable and my problem seems to be fixed.

OLD CABLE (gave problems):

I was using this cable which had decent reviews on Amazon:

Cable Matters Gold Plated DisplayPort to DisplayPort Cable 10 Feet - 4K Resolution Ready http://www.amazon.com/Cable-Matters%C2%AE-Gold-Plated-DisplayPort/dp/B005H3Q5E0/

NEW CABLE (works):

I decided to look at the official VESA DisplayPort site to see their recommended cables (http://www.displayport.org/products-database/). There's only a handful of brands. After searching for them I settled on Accell because of availability. Actually I couldn't find the exact model because the product database only listed 1.1a DisplayPort cables but I hoped that a 1.2 cable from the same manufacturer would work. I got this cable:

Accell B142C-007B UltraAV DisplayPort to DisplayPort 1.2 Cable with Latches http://www.amazon.com/gp/product/B0098HVZBE

Haven't had the issue since changing out the cable.

Note, before changing out the cable, a workaround that worked for me was simply unplugging and re-plugging in the DisplayPort cable from the back of my video card.

OLD ANSWER:

My second monitor wouldn't display in proper resolution in Windows 10 after previously working in Windows 10 (and also in Window 7). I just rebooted one day and the monitor was stuck in 640x480 with no option to change it. I'm using AMD Catalyst 15.7.1. After trying several things I went to device manager uninstalled the Generic PnP monitor driver (i.e. not display adapter driver) and rebooted windows and now it displays the proper native 1920 x 1080 resolution.

  • A good thought, but I did actually try uninstalling Generic PnP, and also rolling it back. To no avail. – Insane Jan 12 '16 at 2:04
  • 1
    @Insane: This problem just happened again to me today. Once again I tried uninstalling the monitor driver and rebooting but the problem was still there. Then I tried uninstalling the monitor driver again AND after that checking the "Make this my main display" (it was originally my main display but after the resolution change my other monitor became the main display) and then rebooting. This fixed the problem for me. Not sure if the multiple reboots did the trick of the combo of uninstalling the driver and setting the main display. – User Jan 15 '16 at 0:29
  • Yeah.. pretty erratic. – Insane Jan 15 '16 at 1:15
  • Yes it is erratic. Happened again today after being fine for a while. The above trick did not work this time. Then I read this forum AMD Radeon HD7700 - Stuck at 640 x 480 Resolution which suggested unplugging and replugging in the DisplayPort cable (what I'm using in my case). No reboot necessary. Do this fixed it for the time being, we'll see for how long. Sounds like a different issue than yours but may help someone else. – User Jan 16 '16 at 11:37
1

In my case this problem was caused by a bad adapter display-port<--->VGA.

Swapping them fixed the third screen resolution issue. (A different monitor worked with this bad adapter).

0

The answer is the monitor.

The answer most likely is the monitor.

As some suggested, the monitor itself was just dying. I bought the exact same monitor new and replaced the one not displaying the native resolution (without changing any cables or connections).

Instantly, it showed the correct resolution.

While I'm not sure what caused this, I know the cause is the monitor itself.

If anyone can give an answer which explains what part of a monitor's hardware would and can cause this to happen, I'll change my accepted answer to theirs.

  • If you google around there are plenty of people having issues with multiple monitors under windows 10. Did you try the monitor on another non-windows 10 machine? Maybe even try a Ubuntu Live CD or something. My second monitor wouldn't display in proper resolution in Windows 10 (after previously working). I went to device manager uninstalled the Generic PnP monitor driver and rebooted windows and now it displays the proper resolution. – User Jan 12 '16 at 1:36
  • @User That's about the only thing I didn't try. But don't worry, I'm not throwing ol' betty away. I'll try another OS the next time the opportunity comes up, but even if this is a Windows 10 thing, why does Windows 10 -- across multiple computers -- hate my specific monitor. – Insane Jan 12 '16 at 2:03
0

Logged in to say I just got this issue as well. Monitor been working well for years Dell U2711 suddenly reports 1680 max res and not the 2540 it should be able to get. Card is a new gtx 1080ti - worked fine for a week with all monitors. Swapped back out to my older gtx690 - same problem exists. Nvida and Windows 10 both just updated - driver and 'creators' updates just applied not sure of the culprit - suspect nvidia. I have a triple monitor setup (all 27" same res but diff brands) and only one screen is affected. Display Port input will not work on it with either gfx card I have or combination of cables, dvi / hdmi work at lower resolution. Cable swapping, port swapping, reduction to just the one screen etc and repeating / trying already all of the opening posts comments do not help. I have a combination of 4 different Display Port to Display port cables - different brands - and no change (dead connection - screen detects the cable connections but adv no signal), also HDMI to DVI and Display Port to DVI (cables not adaptors) work but only at the low resolution on those ports. During POST of the machine I also get nothing via Display port connections. So you'd think its the screen right?

Weird thing is from my Macbook Air 2010 via a mini Display Port (not thunderbolt) to Display Port it works fine - this is the cable I used to use on the gtx690 - same cable tested on that reinstalled card and I get a black screen still. So I suspect firmware update from Nvidia has nuked somthing.

0

I had the same problem. I was using the Acer V226WL monitor with a Geforce GTX 1050 ti graphics card. My fix was to go into the NVIDIA control panel and when I created the resolution I wanted (in my case 1680 x 1050), I also had to change the timing to get the PC to accept the resolution. I changed the timing from automatic to CVT and success! Never had another problem.

0

Had the same issue. I just unplugged all monitors like starting from scratch. Guess Windows got confused after driver install.

0

For my situation, following worked

  1. Remove HDMI cable connected to monitor from computer's HDMI port.

  2. Wait 5 seconds till display is shown on laptop main screen (not sure how this will work for desktop).

  3. Reconnect the HDMI cable disconnected in step 1.

  4. Maximum resolution is correctly shown.

Unfortunately this fix isn't permanent and I have to repeat the process every week or so. I don't want to disconnect - reconnect HDMI cable in order to save wear and tear of the HDMI port. Is it possible to simulate removal of HDMI cable through code or settings change?

0

I had a similar problem on a Surface Book 2, with a Philips 272B8Q ( QHD 2560 x 1440) connected through displayport on the Surface Docking Station.

I already tried updating Windows 10, the Docking station, the Geforce drivers,...

For me, solution 5 of this MS document was the only thing that solved it right away...

-1

I had the same problem. After doing online research, here's what worked for me.

  1. Uninstall all display drivers using this utility provided by wagnardsoft "DDU (display driver uninstaller)"

  2. Manually download (do not use auto detect) AMD/Nvidia display driver from thier website and install. Done!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.