0

Since some point today, my Sublime Text is doing this:

enter image description here

That light grey block is my cursor, focussed on a tab character. It's become a block cursor instead of a vertical line. How do I revert to the default style?

2
  • does it revert once you're out of the tabbed selection, back inside 'normal' text? – Tetsujin Dec 10 '15 at 11:28
  • @Tetsujin: No. I took the screenshot simply to highlight how weird it is, but it appears exactly as a block cursor would in normal text, which is not what I want. – Bobby Jack Dec 10 '15 at 11:37
2

Sublime Text 2 can be reverted to a freshly installed state by removing your data folder. Depending on your operating system, this folder is located:

  • OS X: ~/Library/Application Support/Sublime Text 2
  • Windows: %APPDATA%\Sublime Text 2
  • Linux: ~/.config/sublime-text-2

To revert to a frestly installed state, you can:

  • Exit Sublime Text 2
  • Delete (or move) the data folder, as listed above
  • Start Sublime Text 2 When restarted, a fresh data folder will be created, just as it was the first time you ran Sublime Text 2. Keep in mind that this will also remove all of your settings, and packages you may have installed.

Reference

3
  • Thanks. I'll leave that as a last resort (since I don't want to lose settings & packages). I've tried clearing my user preferences file, and the problem persists, so I'm guessing it might be down to a package. – Bobby Jack Dec 10 '15 at 11:38
  • OK, so the culprit - understandably - was a package called ""Block Cursor Everywhere". I don't understand why, since I definitely haven't installed that package today, although it's possible I installed it at some point in the past. Something must have meant it was inactive before and became active today - weird. Anyway, thanks! – Bobby Jack Dec 10 '15 at 11:41
  • You can copy out the current settings , then reset the configuration as above. Then one by one replace settings file. Hope it do not overwrite your current configuration – shobi Dec 10 '15 at 11:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.