9

I basically don't use my own desktop to do the majority off my work, I RDP out to customers systems and work there. I tend to maximise the RDP session on to one of my screens and work exclusively within the RDP session.

What I've been struggling with since I installed Win 10 is that all the windows control function will sometimes not operate on the remote machine.

  • Pressing the Win key will bring up the start menu on both local and remote system
  • Alt + Tab flicks me back to my local running programs, no the ones on the remote system
  • Win+Cursor keys mess with the RDP client window, not the windows running within the RDP session

I'm not convinced that this is specifically a Windows 10 issue, there are posts here that indicate the same issues going back to windows 7 (here)

However I never experienced this in previous versions of Windows and its driving me nuts.

  • I have tried deleting and recreating my .RDP shortcuts.
  • I've tested with 'Apply Windows Key Combinations' set to 'On the remote computer' or 'Only when full screen', neither make a difference.
  • I'm RDPing from Win 10 (build 10240) to a variety of Windows versions including Server 2003 r2/Server 2008 r2/Server 2012 R2/Windows 7/8. There doesn't appear to be any consistency as to which ones are OK and which ones are not.
  • I am exclusively RDPing to virtualised [ESXi] guests, not that that should make any difference

EDIT : For what its worth I've updated to build 10586.29

EDIT 2 : I've tracked it down to Synergy.

  • Ha! Classic. I occasionally get weird behaviour with my left hand shift/ctrl/win/alt keys and I have to mash them all a few times to stop mysterious behaviour. That one has been following my since the NT3.5 days. Unfortunately your suggestion doesn't seem to affect me though :( – Patrick Dec 15 '15 at 8:29
  • If RDP is set to pass through all key combos to the remote server then the next step is to look outside of RDP. Any third-party software that messes with your keyboard or mouse inputs - hotkeys - game macros - programmable keyboard/mouse buttons - clipboard monitors - etc. – qasdfdsaq Dec 16 '15 at 16:09
  • oooh, thats a good point. Hadn't considered tracking it back that way. You are absolutely right, I use Synergy to use multiscreen; DisplayFusion and Clipboard Fusion both have hooks that might interfere. Will try with these removed and see. – Patrick Dec 17 '15 at 0:03
  • I noticed you're running build 10240. I'm not sure if updating to 10586 might help but it's worth a shot. – Vinayak Dec 21 '15 at 10:07
  • I am unable to reproduce this issue on my system running Windows 10 build 10586, but I think I might have a solution (a very hacky one at best). You could temporarily disable the super key and the Alt+Tab combination using AutoHotkey and see if that helps. LWin Up:: \n LAlt & Tab:: Return, (\n is an actual new line) – Vinayak Dec 21 '15 at 18:51
5

If the above link does go dark, The above link describes how to fix for those unable to use alt tab or winkey shorcuts is a registry key to allow transparent key pass through of the keyboard to citrix.

HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICAClient\Engine\Lockdown Profiles\All Regions\Lockdown\Virtual Channels\Keyboard\TransparentKeyPassthrough

..

or in Windows 7/10 x64

HKEY_CURRENT_USER\SOFTWARE\Citrix\ICAClient\Engine\Lockdown Profiles\All Regions\Lockdown\Virtual Channels\Keyboard\TransparentKeyPassthrough

Set the value to Remote and restart your connection

Either use the link in above comment or the one below, they are both similar. above taken from : http://jonwilliams.org/wordpress/2012/09/25/how-to-enable-alt-tab-in-citrix-remote-desktopreceiver/

  • 1
    Welcome to Super User. The display order of answer posts changes, so "the above link" doesn't really identify anything. Are you referring to Robin Qiu's answer? It's better to specifically identify posts, either by the author's name or the direct link produced by the "share" button under the post. – fixer1234 Jan 7 '17 at 20:54
  • Please format your code correctly. See Markdown help. – DavidPostill Jan 8 '17 at 13:37
4

I am running Synergy.

It seems that there are issues with how it hooks 'special' keys and it keeps them local rather than allowing them to happen at the remote site.

As a bodge round I now have a small script that stops and restarts the synergy services which seems to work round it for 'a bit' (about an hour).

get-service synergy* | restart-service -force
1

I used to have that problem on my (8.1) machine. I was also looking for a solution to manage the number of RDP shortcuts I was building up, and my fix happened in the process of finding that solution, but it may work for you too...

MS has something called Remote Desktop Connection Manager on their downloads site ( https://www.microsoft.com/en-us/download/details.aspx?id=44989 ). Doesn't specify that it works on 10 or not, so YMMV.

Either way: Tools / Options / "Default Group Settings" button / "Local Resources" tab has an option for "Windows Key Combos" that you can set to "On the remote computer".

Now as long as the RDP session has focus, everything happens within that RDP session.

(There is an option in there somewhere for your client session to be fullscreen, as well.)

  • From the OP : I've tested with 'Apply Windows Key Combinations' set to 'On the remote computer' or 'Only when full screen', neither make a difference. I'll try out connection manager though, although I've avoided it thus far as I still prefer my icons and true full screen. – Patrick Dec 15 '15 at 8:34
  • Nuts, sorry, must have missed that line... – s1ns3nt Dec 15 '15 at 18:39
  • Afraid RDCM still exhibited the same issues. – Patrick Dec 16 '15 at 8:12
-1

If you are using Citrix, try this:

http://www.lewan.com/blog/2013/06/14/enable-alttab-application-toggling-in-a-citrix-xenapp-desktop-session

  • Hi there, and welcome to SU. Generally you want to expand on your answers rather than just leaving a link, because links have a habit of going bad and making your answer useless in the future :) – Mikey T.K. Mar 3 '16 at 18:04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.