3

I am running Windows 10 Pro [Build 10240] and upon logging in tonight I find I am unable to install an MSI file as The system administrator has set policies to prevent this installation only, I do not recall doing this, at all.

So I did a little digging and found this post, pretty cool. The best solution on this post was to run the install from an elevated command prompt, so I ran the following command:

msiexec /i example.msi 

This resulted in the same outcome. Using the /a switch also did not help me. So I did more digging and found a "fantastic" Microsoft post here. It applies to Windows 7, so I guess that's why the key does not exist on Windows 10 - the solution was to set DisableMSI with REG_DWORD = 0 in the HKLM\Software\Policies\Microsoft\Windows\Installerdirectory.

So, square 1. Another solution is to set UAC to never notify...isn't this default on a home system? Ran though and double checked it was set to never notify, rebooted, no change.

I wept for hours until I found another option. The next solution I found was to edit the Local Security Policy for Software Restriction Policies. I messed around in here and could not isolate where to add the entry. I added a new hash for %userprofile%\Downloads\ to allow all users to execute file types and ensure MSI was in the list.

I have ensured that my Anti-Virus is not blocking the registry changes, disabled all shields and re-attempted to no luck. I am now performing a full system scan to see if there are any threats on my PC. Long shot, but worth it.

Whilst that is running, I have made a new local account on the PC and ensured it admin rights. I've ran mmc and ensured it in the Local User and Group Administrators group. Once the scan is done I plan on logging out, and attempting to install. I doubt this a user restricted issue but want to rule it out as an issue.

Next I ran gpresult /h report.html and have a quick look to see if I had messed up GPO (I do set local GPO) and all looked well; just my standard disable of gadgets/Cortana etc.

Next I ran sfc.exe /scannow and found no issues here. Frustrated, I went and edited the following values in Local Group Policy:

Computer Configuration > Administrative Templates > Windows Components > Windows Installer with the following:

Install with Elevated privileges set to enable.

Turn off Windows Installer set to disabled.

Same option with User Configuration. The last step is I have redownloaded the MSI and validated it not corrupt (works on Win8 VM). Any assistance would be appreciated.

1
  • “set UAC to never notify...isn't this default on a home system?” No, that would undermine the entire idea. // Don’t forget to accept your answer when you can. :) – Daniel B Oct 7 '16 at 9:11
1

I rolled back to a previous image, and performed a sfc and found multiple errors. I repaired the install, updated (via Windows Update) and now am able to perform the above mentioned.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.