5

I am new to Fedora and I decided to try it on my new laptop instead of Ubuntu. I have an XPS 13 (9343) and the sound is not working. I researched online and found out that people had success installing the latest rc kernel out there.

Kernel found is kernel-4.4.0-0.rc4.git3.1.fc24. What I did was after a bit of googling, I downloaded kernel-4.4.0-0.rc4.git3.1.fc24.x86_64.rpm and tried to install it like this :

sudo rpm -Uhv kernel-4.4.0-0.rc2.git2.1.fc24.x86_64.rpm 

Now I can select the kernel at boot but I don't know how to check if I installed it correctly or not..the file is ~55KB only. Is that all?

I also got the source from that url, installed dependencies and then installed the kernel source like bellow but the kernel doesn't show in the list of available kernels:

su -c 'dnf builddep kernel-4.4.0-0.rc4.git3.1.fc24.src.rpm'
sudo rpm -Uhv kernel-4.4.0-0.rc4.git3.1.fc24.src.rpm

I spent more than 3 hours on this and I couldn't find any good guidance on how to install the kernel...most recommend using dnf install kernel-devel but that's not the version I want.

Do I need to compile the source myself?

How do I add the repository where that kernel resides and try to install it with dnf?

2 Answers 2

9

You could enable the whole rawhide repository, and then just install the kernel. But, for the kernel in specific, we have a better way. The Rawhide kernel is built with debugging turned on, which can be a performance hit. If you want it for new hardware enablement or to get a bugfix early, I'd suggest instead enabling the "rawhide-kernel-nodebug" repository:

sudo dnf config-manager --add-repo=http://alt.fedoraproject.org/pub/alt/rawhide-kernel-nodebug/fedora-rawhide-kernel-nodebug.repo
sudo dnf update

You can also do what you tried originally — just downloading the package and installing it with RPM — but you may run into dependency problems. Also, as you note, the base kernel package is tiny, because it's not the real thing... it's just a "glue" package. You actually need/want kernel-core and kernel-modules.

1

Ok found the answer here after loads of hours of searching so posting for anyone who is interested in this.

Basically needed to install .repo files :

dnf install fedora-repos-rawhide

and then ...install kernel-devel which was the latest that I wanted

dnf --enablerepo=rawhide install kernel-devel

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .