1

I use gpg 1.4.19 on Windows.

Can I communicate with the server directly from the command line? I tried this many things, but nothing worked:

Tried:

>gpg --keyserver hkp://pgp.mit.edu --search-keys vivarto@gmail.com

And got this

gpg: searching for "vivarto@gmail.com" from hkp server pgp.mit.edu
gpg: system error while calling external program: No such file or directory
gpg: WARNING: unable to remove tempfile (out) `C:\Users\Vivarto\AppData\Local\Temp\gpg-5E2480\tempout.txt': No such file or directory
gpg: no handler for keyserver scheme `hkp'
gpg: keyserver search failed: keyserver error

Then I tried:

>gpg hkp://pool.sks-keyservers.net --search-keys vivarto

And got this:

usage: gpg [options] [filename]

I was able to connect to MIC server using email. I don't know how to do that with the pool.sks-keyservers.net server.

Would greatly appreciate any help. Thank you. Vivarto

1

I know this works on Linux...

From the "system error while calling external program: No such file or directory" error it looks like your gpg isn't fully installed or configured. Searching for that error finds this potentially helpful line:

There should be a program named gpgkeys_hkp.exe in the same directory as gpg.exe

Where's your gpgkeys-anything .exe file?

Maybe you need to reinstall or do a full install of gpg

  • Thank you, indeed I did not have the gpgkeys files. Now I added them. I can get the info from the MIT server, but this one >gpg hkp://pool.sks-keyservers.net --search-keys vivarto Is still not working. Here are my executable: 12/09/2015 06:26 PM 965,120 gpg.exe 02/27/2015 10:48 AM 72,704 gpgkeys_finger.exe 02/27/2015 10:48 AM 86,528 gpgkeys_hkp.exe 02/27/2015 10:48 AM 43,008 gpgkeys_ldap.exe Anyway, this is already a huge improvement that I can communicate with MIT key server. Thank you. – Vivarto Dec 11 '15 at 21:18
  • Sorry for the atrocious formatting. Have no idea how to make it look nice. – Vivarto Dec 11 '15 at 21:24
  • Formatting in comments is very limited, pretty much bold, italic, code & links IIRC. The help has more, well... help :-) Maybe you're missing an option to tell gpg to use a different server? gpg on linux uses --keyserver [server] so try it in front of the server. And if the answer works (or is just helpful) please do select/check-mark it (&/or upvote - the up arrow to the left), thanks – Xen2050 Dec 11 '15 at 22:45
  • Thank you this works: gpg *--keyserver* hkp://pool.sks-keyservers.net --search-keys vivarto@gmail.com I have already upvoted last time, and I cannot do it again. – Vivarto Dec 12 '15 at 3:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.