1

I have an triple-booting iMac (Linux Mint, OSX, WINDOWS 10) with rEFInd installed. The following partitions listed using sudo gdisk -l in Linux Mint 17.3:

Number  Start (sector)    End (sector)  Size       Code  Name

1              40          409639   200.0 MiB   EF00  EFI system partition
2          409640       487684319   232.4 GiB   AF00  Customer
3       487684320       488953855   619.9 MiB   AB00  Recovery HD
4       488953856      1074888703   279.4 GiB   0700  WINDOWS
5      1074888704      1949616127   417.1 GiB   8300  LINUX
6      1949616128      1953523711   1.9 GiB     0700  SWAP

The triple boot worked fine until I upgraded from Linux Mint 17.2 to 17.3. After that, I can't select Windows on startup anymore. It seems that the upgrade to 17.3 broke the Windows EFI boot entry (?)

I tried to resolve my issue using the solution listed here: How can I repair the Windows 8 EFI Bootloader

Unfortunately my EFI system partition is not even listed in Windows when I run diskpart and list vol. So I can't assign a drive letter to this partition and run bootrec /fixboot. Does anybody know why it is not listed or how to get Windows 10 back to rEFInd boot menu? My EFI partition is formatted in Fat32.

I had the same trouble when upgrading from linux mint 17.1 to 17.2. At that time I reinstalled windows, which I don't want to do again.

Update 1 - more infomation

rEFInd is still booting, but the windows entry disappeared. There is now an additional linux option "Linux on Windows", which will start linux mint. Here is the results.txt of boot info script: info-script-1. And this one after I ran Windows Repair Disk info-script-after-windows-startupfix

Update 2 - Windows partition: gdisk x -> n -> p

I followed the advise of Ron Smith and used gdisk with x, n and then p (I did not select w yet):

$ sudo gdisk /dev/sda4
GPT fdisk (gdisk) version 0.8.8

Partition table scan:
  MBR: MBR only
  BSD: not present
  APM: not present
  GPT: not present


***************************************************************
Found invalid GPT and valid MBR; converting MBR to GPT format
in memory. THIS OPERATION IS POTENTIALLY DESTRUCTIVE! Exit by
typing 'q' if you don't want to convert your MBR partitions
to GPT format!
***************************************************************

Exact type match not found for type code 7200; assigning type code for
'Linux filesystem'
Exact type match not found for type code 6C00; assigning type code for
'Linux filesystem'

Warning! Secondary partition table overlaps the last partition by
3303746485 blocks!
You will need to delete this partition or resize it in another utility.

Command (? for help): x

Expert command (? for help): n

Expert command (? for help): p
Disk /dev/sda4: 585934848 sectors, 279.4 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): F22799CE-8015-443C-9824-5CB92A0B68FE
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 585934814
Partitions will be aligned on 32-sector boundaries
Total free space is 585934781 sectors (279.4 GiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1      1920221984      3736432267   866.0 GiB   8300  Linux filesystem
   2      1936028192      3889681299   931.6 GiB   8300  Linux filesystem

What I don't understand is the overlapping. sda4 is my windows partion and is only 279 GiB. What should I do about this warning?

Update 3 - Windows appears in rEFInd but still won't boot

Although startup repair failed (using windows installation dvd), windows appears now in rEFInd. But Windows still won't boot (blinking underscore) Windows Startup repair falied with the follwing message:

Startup Repair couldn't repair your PC
Press "Advanced options...
Log file: C:\Windows\System32\Logfiles\SrtTrail.txt
  • Please better describe what's happening. It's not clear if rEFInd is still booting, and if so whether it's showing a Windows entry that's not working or if the Windows entry has disappeared. Also, the output (RESULTS.txt file) of Boot Info Script might help disambiguate the situation, so you should run it and post RESULTS.txt to a pastebin site. Give us the URL so we can better understand what's going on. – Rod Smith Dec 12 '15 at 18:27
  • thx. See above, I added an "Update 1" section – fischermatte Dec 12 '15 at 18:49
  • try ' sudo dracut -v -f -k all && sudo grub2-mkconfig -o /etc/grub2-efi.cfg' and share its output pls and if any new entries show up like windows OR mac and what ones can boot. (from 17.3) – linuxdev2013 Dec 12 '15 at 18:57
  • there is no dracut on linux mint 17.3. when i try to install, it says some dependencies (kpartx, kbd) are not going to be installed. – fischermatte Dec 12 '15 at 19:31
2

Here's your problem:

sda4: __________________________________________________________________________
File system:       ntfs
Boot sector type:  Grub2 (v1.99)
Boot sector info:  Grub2 (v1.99) is installed in the boot sector of sda4 
                   and looks at sector 1516164256 of the same hard drive 
                   for core.img. core.img is at this location and looks 
                   in partition 112 for . No errors found in the Boot 
                   Parameter Block.

This reveals that your upgrade has installed a copy of GRUB 2 to your Windows boot partition. This was either a case of user error or a serious bug in the installation/upgrade process. Unless you have a backup of the /dev/sda4 boot sector, the solution will require using a Windows recovery disk to re-install the BIOS-mode boot loader. Alternatively, you could try converting Windows to boot in EFI mode rather than in BIOS mode. This process is described here, among other places, for UEFI-based PCs. The process would be a little different on Macs -- most notably, you must remove your hybrid MBR in favor of a conventional protective MBR rather than convert from MBR to GPT. I also can't promise that it would work on your particular computer; you could just make matters worse by trying.

  • after running windows repair and fixboot/fixmbr, sda4 seems to be correct now (without grub). See here for results.txt pastebin.com/RLRcdUvP. Anyway, I can now select Windows at refind options but after that there is only a blinking underscore. Any idea? – fischermatte Dec 12 '15 at 21:28
  • could you tell me how to convert hybrid MBR to protective? – fischermatte Dec 12 '15 at 21:51
  • I have no further ideas about repairing the Windows boot, since I'm not a Windows boot expert, especially not in BIOS mode. As to converting a hybrid MBR to a protective MBR, a lot of partitioning tools will do this automatically when you make any change. To do it deliberately, you could use my GPT fdisk (gdisk): Launch gdisk on the disk, type x to enter the experts' menu, type n to create a new protective MBR, and type w to save your changes. (Typing p to check your partitions before saving your changes is worth doing.) – Rod Smith Dec 13 '15 at 3:12
  • thx ron. I ran the commands (see update 2) but without using w yet. I didn't know what to do about the overlapping sectors warning. should I ignore it? – fischermatte Dec 14 '15 at 9:05
  • You launched gdisk on /dev/sda4, which is wrong; you should launch it on a whole-disk device (probably /dev/sda). – Rod Smith Dec 14 '15 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.