0

In trying to create a junction link for my iTunes backup folder, I accidentally pointed to a directory called "Computer/MediaSync"

This occurred because I forgot to use quotation marks around the directory and the Apple Computer directory has a space!

The command I used was:

mklink /J C:\Users\Myname\AppData\Roaming\Apple Computer\MobileSync E:\iTunes Backup

The response showed

Junction created for C:\Users\Myname\AppData\Roaming\Apple <<===>> Computer\MobileSync

I tried deleting the "Apple" shortcut that was created, but I cannot recreate the junction. When I try it is responds with "Cannot create a file when that file already exists"

I am trying to run the following and it never works.

mklink /J "C:\Users\Myname\AppData\Roaming\Apple Computer\MobileSync" "E:\iTunes Backup"
0

Like the message states: if you have an existing directory (in this case ...\Apple Computer\MobileSync), then you can not turn it into a junction or symbolic link with the mklink command. You need to delete that folder, and then recreate it (with the same same if you wish) with the mklink command.

  • Thanks. I figured that out and moved the actual mobilesync directory (effectively deleting it) and then my junction worked. – linkedchallenged Dec 13 '15 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.