16

I am trying to format my SD card to FAT/FAT16 and when i run DISKPART in windows 10 all I get is this:

Why can't I use this utillity? I am running this as administrator. I can't enter anything, no LIST DISKS or anything.

3
  • 1
    I can't enter anything This is because it hasn't loaded yet try a reboot of the system. That worked for me
    – Racing121
    Dec 13, 2015 at 23:06
  • 1
    try using diskmgmt.msc or a 3rd party partitioning tool. They're much more advanced than MS tools
    – phuclv
    Mar 19, 2017 at 5:14
  • If the current OS is installed anywhere other than the internal hard drive, DISKPART might not recognize it. Sep 23, 2017 at 5:02

4 Answers 4

8

Diskpart only hangs if there is a problem accessing one of the disks detected via the controllers.

Remove the card and run diskpart. If it works correctly, it means the SD card is defective. If it does not, it means there's a problem with one of the other disks/controllers.

Also, be patient, it may take some time to read a disk with problems. Wait for a few minutes.

4

Try to take out your SD card and then see if DISKPART loads. If it does load there may be a problem with the SD card or SD card reader that is causing it to hang.

As an alternative you can open a file explorer, right click on "This PC" choose "Manage" and then select "Disk Management" from the left pane. You should be able to format you SD card from here as well. But if this hangs as well I would try a different SD card.

1
  • 5
    The point being to use DISKPART to fix the disk, if that one hangs... Happening to me with an external hard drive, something seems broken on it and I can't use diskpart to fix it, not quite useful here. :/ Jul 12, 2016 at 5:10
2

Hoping this helps others that have this same or similar problem.

Removing the disk will allow the command to finish. Reinsert the disk back into the drive and then run List Disk and you should now see the disks.

  1. Type Select Disk X (where X=disk number)
  2. Type clean (deletes all data on the card)
  3. Type create partition primary
  4. Type format quick
2
0

This can happen if you have Disk Management Console busy using the Virtual Disk Service. So you can try:

sc stop vds
sc start vds

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .