I'm trying to access an intranet server under HTTPS, whose certificate has been autogenerated. With other browsers (IE, Firefox, Chrome, etc.) I have the option to ignore this error and to somehow "go ahead at my own risk".

In Edge I only see a red "Certificate error" message, but I cannot find a way to tell the browser: "don't worry, it's OK, just ignore it and go ahead".

Any suggestion?

Note: OS is Windows 10


  • Edge only supports SHA2 authority-signed certificates. Either SHA1 or self-signed certificates will fire alarms. (I'm fighting this issue myself and this is the only possibility that seems left.)
    – MPelletier
    Mar 19, 2017 at 4:00

3 Answers 3


On chromium edge type thisisunsafe while considering that it is, indeed, unsafe.

  • 4
    Did not expect that to do anything, haha 😅 (it did)
    – Svish
    Sep 1, 2021 at 13:00
  • 2
    Is this serious? Where should we type thisisunsafe? In developer console or address bar? Nov 15, 2021 at 8:30
  • 2
    @kiranpradeep click somewhere on the page and just type it. There is no feedback before it works
    – Schaki
    Nov 15, 2021 at 12:02
  • 1
    Thanks. But it didn't work for me for Microsoft Edge Version 96.0.1054.29 (Official build) (64-bit). Maybe since it's browser managed by origanisation. I use a different browser now, so not a problem anymore. Nov 23, 2021 at 13:40
  • 1
    @kiranpradeep new to this trick, and it worked on Version 101.0.1210.32 (Official build) (x86_64) on macOS, but not on Windows for some reason. There are lots of possible settings to go through. Oh actually, on Windows you can click "Turn off warnings". May 6, 2022 at 5:32

Update - August 10, 2019

In the recent version of Microsoft Edge, you can do this. So, if you don't see the bypass option, you might have to update/upgrade Windows 10 to update/upgrade Edge. If a major version of Windows (ex: 1903) are not offered automatically through Check for updates, you can get the updates manually through the Update Assistant.

Link: https://www.microsoft.com/en-us/software-download/windows10

In Windows 10 1903, you can bypass the certificate error by clicking the 'Details' and then clicking the 'Go on to the webpage' link. This is not recommended since it can be dangerous.

Edge - Screenshot


This is what that screen looks like for me... Specifically, this is for an internal (intranet) site that uses a certificate which is signed by a trusted internal CA, but I'm going to the wrong URL (the cert is for brains.corp.<company>.com, not just brains), which triggers the untrusted certificate error screen. Screenshot of Edge visiting a site with an untrusted certificate Do you just not have the "Continue to this webpage (not recommended)" link? Clicking that lets me through to the "untrusted" web page just fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .