0

I have Fedora 23 installed with VLC 2.2.2-0.1.fc23. When I open any H.264 video in VLC, when seeking it does not seem to synchronize to I-Frame. The video is distorted for a few seconds.

It works fine on two other machines with Fedora 22-23, only difference I can come up with is that those have Intel graphic cards.

The affected machine has NVidia GeForce 750 Ti with proprietary drivers installed from RPM Fusion. They seem to work fine, at least when testing OpenGL. I have also installed VDPAU/VAAPI drivers, as explained at http://rpmfusion.org/Howto/nVidia .

I have tried to disable hardware acceleration in VLC, "Video / Accelerated video output (Overlay)", no effect. Also tried changing "Input/Codecs / Hardware accelerated decoding". It did change a bit, but did not fix the problem.

Interesting is that playing the video in FFplay, Banshee, Totem, MPV, or SMPlayer works fine.

Any idea how to debug and fix this issue?

0

I saw the same problem with vlc-2.2.2 playing x265 encoded video - huge pauses until the video was back in sync after any seek.

I solved it by changing the video output module (Preferences -> Video -> Output modules) from "Automatic" (which actually selected "VDPAU") to "XVideo putput (XCB)". So the problem must be with the VDPAU output.

  • Unfortunately, I have tried all options and either I encountered the same problem, or video playback did not work. With "XVideo putput (XCB)" I have no video playback at all. – Fenikso Feb 21 '16 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.