3

I just rebuilt my desktop and decided to upgrade it to Windows 10. The upgrade went smoothly and everything is working except one thing. My computer has multiple monitors and I am used to using the keyboard shortcut Win+Shift+ Left or Right to move the active window between the screens. In my current setup, this feature is not working.

Other shortcuts that I am aware of still work (Win+M to minimize all, Win+E to launch Explorer, etc.). I've looked around through all the settings I can find but have found nothing relating to this option. Anyone know how to restore this functionality?

4

Further looking around for answers to this problem finally paid off. Turns out the problem can be found in Control Panel => Ease of Access Center => Make the keyboard easier to use. In there, under the heading "Make it easier to manage windows" is the setting "Prevent windows from being automatically arranged when moved to the edge of the screen". Checking this box disables some of Microsoft's "Aero Effects", such as dragging a window to the edge of the screen and having it fill half the screen instead. I turned that off a while ago because I didn't like the auto-widening it did, however it also disables the keyboard shortcuts to move the windows between screens. (Not sure how those are related and not separate checkboxes here, but oh well.)

The solution that I had to keep the rearranging off but still enable the shortcuts was to install WindowPad, a spin-off of AutoHotKey. Because I made these changes several years ago, I had totally forgotten changing them or how I resolved it. I think it carried over to my new install because of my linked Microsoft account (which kept the disabling setting but not the WindowPad fix).

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.