0

I have a Philips 202p4 CRT monitor, maximum resolution is 2048x1536, uses a VGA cable.

My desktop running Windows 7 supports the maximum resolution. The monitor driver is Generic PnP

When I plug the monitor into my windows 10 notebook (with the latest Intel drivers for HD 4600 and internal display disabled), the maximum resolution is 1280x1024. I know the maximum resolution from my notebook's vga output is higher than 1280x1024 because I can output 1680x1050 on my LCD monitor via VGA.

I haven't been able to find x64 compatible drivers for the monitor, but seeing as the Generic PnP drivers worked fine on my Win7 machine, I assume they should also work fine on Windows 10.

How do I use the maximum resolution from my notebook?

EDIT1: When I dump the EDID info from the monitor, it shows all of the supported resolutions:

 720 X  400   70 Hz
 640 X  480   60 Hz
 640 X  480   72 Hz
 640 X  480   75 Hz
 800 X  600   60 Hz
 800 X  600   72 Hz
 800 X  600   75 Hz
 800 X  600   85 Hz
 832 X  624   75 Hz
1024 X  768   60 Hz
1024 X  768   70 Hz
1024 X  768   75 Hz
1024 X  768   85 Hz
1280 X 1024   75 Hz
1280 X 1024   85 Hz
1600 X 1200   75 Hz
1600 X 1200   85 Hz
1792 X 1344   75 Hz
1920 X 1440   75 Hz
2048 X 1536   75 Hz

So the monitor itself is reporting the correct resolutions.

  • Where did you get the "latest" display adapter drivers you're using? If you didn't get them directly from the manufacturer (ie: Intel), go get and try the latest one they offer. – Ƭᴇcʜιᴇ007 Dec 16 '15 at 20:30
  • I downloaded them directly from the Intel site. – A G Dec 16 '15 at 20:39
  • What refresh rate do you have set for the monitor? According to some specs I found, you need it at 80Hz or lower to get the max. resolution for that monitor. Perhaps try dumping it down to 60Hz and see if higher resolutions become available. If so, pick it, and then bump the Hz back up as high as you can (at the resolution you want). – Ƭᴇcʜιᴇ007 Dec 16 '15 at 20:49
  • FWIW you probably don't want to use a resolution higher than the recommended 1600x1200. Use test patterns to see how well each resolution resolves vertical & horizontal lines. Anything other than the optimum resolution will probably produce Moire and banding issues. – sawdust Dec 16 '15 at 20:57
  • I set the refresh rate to 60, but the list of available resolutions is the same. – A G Dec 16 '15 at 21:41
0

In Windows 7, you could go to screen that lets you adjust Screen Resolution, press a hyperlink that says "Advanced Settings", go to the "Monitor" tab, and uncheck "Hide modes that this monitor cannot display". Then go to the Adapter tab and choose the "List All Modes" button.

Windows XP was similar, if not identical. I suggest checking for something like that in Windows 10.

That's the unclassy way. The classy way is to use non-generic drivers that are designed specifically for your monitor. However, using "Generic"-style drivers can be more compatible, and convenient.

  • I looked at that, but the list all modes tops out at 1280x1024@85hz. I couldn't find non generic drivers, but if the Generic PnP drivers work on my win 7 desktop, I assumed the Generic PnP drivers work in windows 10 as well. – A G Dec 16 '15 at 20:42
  • If the results of the "List All Modes" button top out at 1280x1024, then that is consistent with the slider bar topping out there. That's why it is so important to uncheck that checkbox, which has the effect of modifying what shows up when the "List All Modes" button is used. You didn't really jump to the end of the paragraph and skip the middle, did you? – TOOGAM Dec 16 '15 at 20:48
  • I unechecked the "Hide modes" box, but it has no effect on the list. I think in older versions of windows, it would show everything but on my list it doens't even show 1366x768 which is the notebook's resolution. – A G Dec 16 '15 at 21:41
0

After some more research, it appears that it is limited due to the Haswell's VGA DAC (Digital to Analog converter). It is limited to 180Mhz, whereas on my desktop, the DAC on the integrated Intel graphics is 400Mhz.

When I use the Intel drivers to specify a custom resolution of 1600x1200@60hz, it works, but 1600x1200@75hz fails with the error "The custom resolution exceeds the maximum bandwidth capacity". There is no option for CVT-RB (Reduced blanking) as the blanking interval is required for CRTs to function properly.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.