4

Today, I was working and I tried to access the taskbar. However, it didn't pop up. I moved my mouse off of Firefox and the taskbar unhid, as it should have, but Firefox was on top. As far as I can tell, every time I move focus to Firefox, it goes over the taskbar.

Now, this is a problem. I need to be able to access the taskbar whenever I want to, without moving my windows around to get a clear look at the desktop. (Yes, I'm aware that there's a button on the taskbar to minimize all windows, but the key thing here is that it's covered. Like the rest of the taskbar.) As far as I can tell, this is only happening with Firefox, though I do remember it happening with other applications, albeit not every time I focus the window.

How can I stop the taskbar from being hidden by Firefox? Is it possible to do this without compromising the ability to allow full-screen appliations to go on top?

I've done a bit more testing, and at least at the moment, this is what's happening:

  1. I'm having a wonderful day, editing this post.
  2. I move my mouse to the bottom of the screen:

    Confetti rains from the sky in a glorious hail of death and terror.

  3. I sigh exasperatedly and click on the taskbar.

  4. The taskbar goes above Firefox.
  5. I do whatever I had to do with the taskbar.
  6. I go back to Firefox.
  7. Repeat.

NB: I am explicitly not looking for a one-time solution. Sure, it's just another couple of clicks and maybe a drag, but having to do that every time is a pain in the cloud.

NB 2: Also, it's not every time I start Firefox, only about one in ten (ish; I haven't been using Win10 much).

  • Do any other Windows behave like this? There was a similar post I found, they recommended restarting in Safe Mode and then try going back to normal mode. – MC10 Dec 17 '15 at 0:09
  • 1
    @MC10 None that I've used so far. Whenever Firefox is exhibiting this problem, though, it seems to bring all other programs on top of the taskbar as well -- They hide it too. – Nic Hartley Dec 17 '15 at 0:10
  • Some other related questions 1 2. Are there any possible culprits like third party programs or drivers? Try killing explorer.exe and restarting it. – MC10 Dec 17 '15 at 0:57
  • @MC10 I will, as soon as the problem appears again. It only happens every few Firefox starts (I added the note down there at the bottom). Naturally, of course, it hasn't appeared since I posted this question. Beautiful. – Nic Hartley Dec 17 '15 at 0:59
  • 1
    So far @Epat below gave me the only working workaround I ran into so far. Hit F11 twice. It works for me. – Don King Nov 23 '18 at 8:53
2

"Show desktop" never worked for me, but I've noticed that if I hit F11 twice, the taskbar returns to normal. Not that that's any kind of solution, but it's easier than restarting FireFox.

  • You know what? This actually worked for me :) Ive tried everything else without effect, but this little trick brought back the taskbar on top of Firefox. Ive been trying to fix this for months with no avail so this fix is a huge step forward! Thx! – Don King Nov 23 '18 at 8:51
1

I'm having the same problem too. I briefly managed to get it to behave with the "Show Desktop" command (like the original poster I used dual monitors), but this time it failed. Using Process Hacker I was able to verify that generally all Firefox windows are set to "Always On Top", even tabs that aren't active. (Miscellaneous > Windows). Toggling that doesn't work either. I also noticed another program beneath it (Pidgin) also had all its tabbed windows set to "Always On Top". After turning the flag off on all the instances AND doing a Explorer restart in Process Manager it finally behaved. I suspect it's a bug in Explorer in Windows 10.

0

Sounds like you have Firefox in full screen mode. Press F11 on your Keyboard to return it back to a normal window.

  • No, I don't. Like I said, it's a separate window. Good thought, though, and not something I'd have noticed if I was in fullscreen. I'll attach a screenshot to show better in a moment. – Nic Hartley Dec 16 '15 at 23:26
  • There, posted steps and a screenshot. Does that clear anything up? – Nic Hartley Dec 16 '15 at 23:36
0

I've had it happen a few times now, and so far the following things have worked:

  • Restarting Firefox (though this is not always an option)
  • Restarting Explorer (causes some bugs of its own, though these are easier to fix)

I'm trying new things every time it happens, but so far it hasn't happened often enough for me to check many things, and I keep restarting Explorer before remembering I have other things to test.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.