When I run the terminal in my elementary OS(Ubuntu 14.04 dist) it appears as follow:

Support: command not found

the first line (Support: ...) appeared after trying to install nodejs but I had problems to install it and I tried to install like 5 times in different ways and finally I could install it. But the "Support: command not found" appeared each time I run the terminal.

I'm new in ubuntu and I don't know what it refers with Support but I can type some commands like ls, cd, sudo apt-get and those work fine. So, please someone can help me?

Thanks in advance

  • You see this everytime you startup the terminal app? Might be something hardcoded in your profile....( ~/.profile ) Edit/view this file to see if has any mention of the "support" cmd. Also.....look for a strange configuration in your bashrc or a mistyped parameter in your launch-terminal command in your menu. ( ~/.bashrc )
    – Stephen R.
    Commented Dec 17, 2015 at 2:05
  • When you said that I have to check the "profile" you were talking about the .profile that is located in /home right??? I will check that. And Also i was checking the bashrc but I don't know how to interpret the code and how to identify if something is wrong.
    – Anargu
    Commented Dec 17, 2015 at 3:35
  • I read .profile was only read when logging in the first time - if already logged in and open a terminal then just .basrc & maybe one other is run
    – Xen2050
    Commented Dec 17, 2015 at 12:11
  • To start try grep Support ~/.*... then if you find check from where it is called from. It's a row strart. Else more clean you can follow line by line your initialization files. You shoul find around the end if it is an addition. Last you shoul have eaten a # character somewhere especially if you edited by hand... good hunt.
    – Hastur
    Commented Dec 18, 2015 at 5:32
  • Welcome aboard. Just curios - since you have posted on, and are aware of, our Ubuntu and Unix & Linux sister sites, why ask this question here?
    – Mawg
    Commented Jan 8, 2019 at 7:35

3 Answers 3


The bash error "xxxxxx: command not found" shows up when you try to run a command/program that's not installed or not in the path, etc. Per Hastur's comment, searching for "Support" in .bashrc is a great idea, and check .login & .profile too if they exist (I don't think they should be running just for opening a terminal.

Could be in the ~/.bashrc file. In general to find a mystery error I'd test it like this:

Try opening a terminal and type

source ~/.bashrc

If the error shows up, then it's definitely something in there that's the problem. Look through the file for the line that causes the error - could go line by line pasting into a terminal if it's not overwhelming, or add echo "step 1" ... echo "step 2" etc lines to narrow it down. Then remove/modify the offending line.

  • When I put in the terminal: source ~/.bashrc then the terminal returns another Support: command not found So I will check the file...
    – Anargu
    Commented Dec 18, 2015 at 16:20
  • It does show up then? Just open & edit .bashrc then, and fix/remove/comment out the line that's got "Support ...." in it
    – Xen2050
    Commented Dec 18, 2015 at 16:34
  • Yes, I could solve the problem I think, because I just commented a piece of code then The "support command not found" dissapeared. The origin of the problem is because I installed nativescript (nativescript.org) and part of this installations went to the bashrc file.
    – Anargu
    Commented Dec 18, 2015 at 16:55

Thanks Xen2050, I was checking my bashrc file (with echo "step1"...)and I found this part:

if [ -f /home/anargu/.tnsrc ]; then 
    source /home/anargu/.tnsrc 

Well I coul identify it because I installed nativescript (https://www.nativescript.org/) and this part of code correspond to it. When I commented (put several "#") those lines, the:

Support: command not found just dissapeared.

I think I solved this problem just commenting that part of code because then I couldn't find any problem at the moment. Thank you so much!

  • No problem, I'll give it an upvote :) those lines source (like "read/load") the /home/anargu/.tnsrc file, it must contain the "Support ..." line, maybe it's a comment that's not commented, maybe there's a program that wasn't installed correctly, or something else. If there's anything else in that file you want/need you could fix it, but if everything works well now then why bother ;-)
    – Xen2050
    Commented Dec 19, 2015 at 15:19

Answer by @Anargu lead me to the source of the problem. In ~/.tnsrc I had a comment on the first line that hasn't actually been commented out. The first word of the statement was Support, that's why the error showed that word.

I've opened the file, deleted the line, and the error stopped showing up.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .