1

when I try to start i3 I get the error:

Error while loading shared libraries: libcairo.so.2: 

(Then the rest of the the error is cut off)

How can I fix this? What does this mean? Note, I am an arch newbie and I was trying to get infinality working before i3 crashed

1 Answer 1

2

The error message means that the library with the name "libcairo.so.2" could not be loaded.

I guess you will have to install the library. Something like:

pacman -S libcairo

But usually if its a dependency it should have installed that library automatically. Best practice is to use the package manager of a distribution to install software. E.g.

pacman -S i3

P.S. more information about the system and the problem would make it easier to give you a specific answer.

1
  • I already tried the first command before asking this question, but much to my surprise, the second command actually worked. Thanks!
    – bs7280
    Commented Dec 17, 2015 at 4:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .