1

Now that I almost disconnected our file server, I need to ask the question:

Has Microsoft changed how the Clipboard works?

I am currently working on our IT documentation. I needed to verify that a certain setting has a certain value. So I fired up my PowerShell as an Administrator on my local computer and entered a PSSession to our file server.

I ran some PowerShell commands (only Get-s), marked some of the output and right-clicked to copy the marked text. You must understand, copy & paste is one of the things I am most experienced in and I even put it into my CVs with great success! I am doing it for years now …

So, I right-clicked again to paste the text right after | fl. But it suddenly pasted the following line I copy-and-pasted earlier from/to our IT documentation: New-NetIPAddress -InterfaceAlias "Ethernet" -IPAddress "10.0.0.6" -PrefixLength 16 -DefaultGateway "10.0.0.1". Gladly I was working on the same server the command belongs to.

This is not the first time that this happened on Windows 10! It seems they changed something in the clipboard functionality. At first I thought that processes that I run as Administrators use a separate clipboard for security reasons, but I still am not able to reproduce this weird behaviour. It just happens from time to time while working with Windows 10.

3

They haven't changed the way the clipboard works per se... but rather they changed the way the "Console Host" which hosts Powershell and cmd.exe works. They basically just added support for the copy and paste hotkeys (Ctrl+C, Ctrl+V, etc.) natively, so that you don't have to fiddle with the mouse quite as much as you used to if you wanted to copy and paste at the command prompt. If a program is currently running, Ctrl+C can still interrupt it, but if no program is currently running, Ctrl+C copies highlighted text into your clipboard. Right-clicking can still paste it the way that it used to, but now so can Ctrl+V. This behavior might seem unexpected until you get used to it, but it's quite purposeful. Now go update your CV!

| improve this answer | |
  • Thanks for the answer. I know that and it is not what causes the problems. Unfortunately … because then I could fix it. – Daniel Dec 16 '15 at 13:53
  • 1
    Since you mention remote servers, what you may have experienced was a failure of the rdpclip service, either on your client or the remote host. This is the service that keeps your local clipboard in sync with the remote server's clipboard that you are connected to via RDP. – Ryan Ries Dec 16 '15 at 14:27
-2

Though I discovered this welcome change soon after I stood up the H-P Z-240 workstation that is now my primary development workstation. I have observed this behavior since Day 1, and all of that experience is with Windows 10 Professional, 64 bit, version 1709. As of today, my build is 16299.192. The machine has 32 GB of main memory. The boot drive is a 512 GB SSD that has 371,052,199,936 bytes free. I also have a 2 TB magnetic drive spinning at 7200 RPM, which has 1,951,814,074,368 bytes free. Stranger still is that there seems to be a disconnect between certain applications and the system clipboard. While the main clipboard contains "1,951,814,074,368 bytes free," the clipboard in my text editor (IDM UltraEdit Text/Hex Editor (x64), Version 24.20.0.51 sees something entirely different, which I would need to hand copy into this message. Even stranger is that I had no trouble copying the version information from its About Box.

This final observation makes me wonder whether the issue is confined to EditControl windows, according to Spy++.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.