1

Internet Explorer 11 x64 on my Windows 7 x64 machine will not stay logged in to any site that allows users to stay logged in (e.g. Facebook, ISP, Stack Exchange). My ISP is ATT.YAHOO.COM. As soon as I close IE and reopen it, all the sites to which I was logged in to require me to sign back in. Mozilla Firefox has no such problems. (Yeah, I know, I could use Firefox instead of IE, but I'm kind of used to IE.) I'm just about at my wit's end trying to figure out what's wrong.

In Tools > Internet Options > General tab "Delete browsing history upon exit" the checkbox is unchecked.

In the registry under "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\5.0" I tried renaming Cache and LowCache to Cache-Old and LowCache-Old. I tried this yesterday (Dec 12, '15), and at first, it seemed to work. After applying that fix and rebooting, I was able to stay logged on to the sites I frequently visit during the day, but this morning it was back to the same old behavior, not being able to stay logged on to ISP, Facebook, or Stack Exchange.

Also, when I do log on, I have to log on twice. For instance, when I logged on to Stack Exchange, I had new reputation change, but when I clicked on that icon, I was asked to log in again.

This used to happen intermittently, but now is constant. Sometimes after several reboots, I could get IE to stay logged in, but it seems that doesn't even work anymore.

EDIT: Same behavior with 32 bit IE. Also, Add-Ons that are enabled are Java, Norton Toolbar and ID protection, and Free Download Manager, none of which have ever caused problems.

Update: If I just navigate away from the site I have logged in to without closing IE, I still have to reenter my credentials again.

Update Jan 23, '16: Here are the things I've tried so far:

  1. Reset Internet Explorer defaults.
  2. Manually deleted cookies.
  3. Deleted browsing history.
  4. Set Temp Internet Folder from 250 MB to 500.
  5. In "HKCU\Software\Microsoft\Internet Explorer\Privacy" set CleanPassword to 0
  6. In "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\5.0" renamed "Cache" and "LowCache" to "Cache-Old" and "LowCache-Old" respectively.
  7. In "Tools > Internet Options > Advanced > Security" unchecked "Empty Temporary Files folder when browser closed."
  8. Uninstalled and reinstalled Internet Explorer 11.
  9. In "HKCU\Software\Microsoft\Internet Explorer\BrowserStorage" set DefaultDomainCacheLimitInMb to from 1 to 500.
  10. In "HKCU\Software\Microsoft\Internet Explorer\BrowserStorage\AppCache" set AllowWebsiteCaches from 1 to 20.
  11. In "HKCU\Software\Microsoft\Internet Explorer\BrowserStorage\IndexedDb" set AllowWebsiteDatabases from 1 to 16.
  12. Ran Internet Explorer with all add-ons disabled
  13. Disabled Norton Antivirus
  14. Deleted "HKCU\Software\Microsoft\Internet Explorer" and imported that same key from March '15 registry backup

6 - 11 and 14 worked initially, but upon next day's restart, it was still broken, and redoing them only worked the one time (i.e. they didn't work again).

If anyone sees anything I may have missed, please post. I'm sure it would be helpful not just to me but to anyone else who has experienced this in IE 10 or 11. The replies I see in Microsoft's forums are less than stellar.

  • 1
    It sounds to me like no cookies are saved. Either that is some setting somewhere, or your 'Temporary Internet Explorer Files' directory is corrupt or overflowed or something. If you know how to find it, remove the whole die (at max you lose your cookies, but it seems you don't have any anyway); otherwise, try the clear cache and cookies. – Aganju Dec 18 '15 at 5:44
  • @Aganju, I thought of that after I posted this and cleared my Temp Internet Folder; same effect. I also changed its size from 256 MB to 512; again, same effect. And I ran CHKDSK /R /X about a week ago. – BillDOe Dec 18 '15 at 6:37
2

I wanted to answer this rather than delete the question so that it might show up in a search engine.

I somewhat suspected that Norton Internet Security (NIS) may have been the cause of this issue, but some of the steps I took in troubleshooting it, such as disabling Norton, seemed to indicate otherwise. Also, this issue did not occur for several months after installing NIS.

Finally on January 21 I completely uninstalled NIS. Quite frankly, it did more things (idle time security scans, which cannot be disabled, for example) than I really want from an antivirus, and its site advisor feature was pretty inconsistent, in that search results often didn't display the Norton icon indicating a particular site was safe. Since uninstalling NIS, Internet Explorer has kept me logged in to my ISP, Stack Exchange, Amazon, and Facebook.

I have since installed BitDefender has my antivirus and like it very much. It is not intrusive at all, and its site advisor works even in Facebook.

My issue with Internet Explorer not keeping me logged in has been resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.