0

I've been using this (Dell SK-8115) USB keyboard with my desktop Windows 7 / Ubuntu computer for years without any problems.

Yesterday, while running Windows 7, I found that pressing the * key on my numeric keypad was not producing any character. Shift-8 would still make a *. The other keys on the keypad seemed to make their characters, and toggling the Num Lock state had no effect on the * key, which did nothing. Typing with other keys seemed to work fine. I restarted the computer, and the * key has worked since then.

What could have caused this?

Edit: Rebooting or booting into Linux did seem to remove the problem. I didn't notice it again for several days. One comment suggested I try removing, cleaning, and re-attaching the key. Since it was working with no sign of unreliability except when it wasn't working at all, I decided to wait to do that until it wasn't working again (because if that was the problem, I wouldn't know if I tried to fix it while it was working). That happened last night, so I investigated more carefully. I hadn't noticed before that the / key on the numeric keyboard also was not working. I removed the * key. It looked clean, and pressing the sensor itself had no apparent effect. I put the key back and it still didn't work, but then I found what was causing this in my case (see my answer below).

  • keyboards do wear out. if you boot from a live CD, does the button work again? if not, then you should look into replacing the keyboard (which you can do on a laptop most of the time). – Frank Thomas Dec 18 '15 at 0:06
  • As I wrote, I restarted after a while and it has so far worked just fine both in Ubuntu and Windows since then. ***************************************** <- I just tested and it seems as solid as ever, where while it wasn't working, it didn't produce any * at all. – Dronz Dec 18 '15 at 0:16
  • Take the top of the key off and reseat it. – whs Dec 18 '15 at 0:17
2

This was caused by software intercepting the input on those keys.

As described in my edit to the question, it took a while before I noticed the problem happen again. I ruled out that it was a dirt under the key top (there was none, and pressing the sensor also had no effect, and I found that the / keypad key was also doing nothing). Then I noticed something else that identified the problem:

Not long ago, I had installed Nuance Dragon Naturally Speaking (Premium) 13. This is dictation software, but it has a "feature" I hadn't learned about yet, which is while the program is loaded, it intercepts certain keys' input, including the numeric keypad / and * keys. I was able to clear that out by going to that software's Tools->Options->"Hot keys" menu and editing out those keys.

This is very similar to the problem and solution in this question, but with a different piece of software doing the interception. So as a general answer to this type of problem, I would suggest that if some keys stop responding sometimes, one might try shutting down various running programs (especially recently-installed ones) and then testing the keys, to see if any of them is causing it, and then looking for options in that software to hopefully see what keys it intercepts and adjust them to taste (or at least know what they are).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.