I have an Acer Aspire One AO150 and am having trouble plugging in an external monitor under Ubuntu 9.10. There were no problems under 9.04. If I plug in an external monitor once the machine is already up, then bring up the 'display' application to activate it, it basically hangs. There are no problem under these circumstances if I have desktop effects turned off. I've seen a few mentions of this problem on the Ubuntu forums, but never a solid solution. Any ideas?

A few more details after a question below. The machine does not respond to its keyboard commands to switch to an external monitor, nor does it respond to Ctrl-Alt-F1, etc to switch out of X. The pointer is visible on the monitors (at the edge of each) and is frozen as a 'busy' cursor, but with no animation. The kernel does respond to SysReq commands (REISUB).

In the latest attempt I had the external monitor active earlier, then removed it and activated desktop effects. Upon plugging in the eternal monitor then bringing up the display application, it hangs.


There is a bug (launchpad bug) in 9.10 that blocks the X server upon detection of external display when running compiz. You can get around this by running metacity (metacity --replace).

  • Thanks! I'd actually already found this workaround, and the bug. I'm a bit disappointed that it's taking such a long time to fix. – Nerdfest Mar 1 '10 at 13:10

This is an issue with the maximum virtual resolution that compiz can hanle for the netbook graphics chip (Intel GMA950). This can be solved (worked around) by changing the positioning of the external monitor. You could read my post about this issue : http://www.geekytalk.snaga.net/2010/03/compiz-and-virtual-resolution-handling.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.