I have a Windows 10 PC that has a problem accessing a network share.

The firewall is disabled, network is local, I tried accessing by IP address or domain name. Same workgroup. What is even more weird, from a Ubuntu VM on the same PC I AM able to access the same share, so it's something in Windows settings and not a networking problem.

I've went through quite a few answers on Super User and the web, but so far nothing worked.

  • Do you get any decent error messages? Does the connection time-out or anything else? As it stands, it is impossible to diagnose the problem.
    – R-D
    Dec 18, 2015 at 10:58
  • Windows 10 introduced a new version of the smb protocol and is possible incompatible with Sambe at the moment Dec 18, 2015 at 11:09
  • no meaningful messages :( and btw, I have another Win10 Pc on the same LAN and it accesses the share just fine
    – reflog
    Dec 19, 2015 at 11:31
  • I have got the same problem. I can ping the device but cant access the Network Share drive.
    – Marshal
    Jan 5, 2016 at 16:10

2 Answers 2


Try How to detect, enable and disable SMBv1, SMBv2, and SMBv3 in Windows and Windows Server. Windows 10 tries to negotiate SMB3_11, which Samba does not yet support.

Another possibility UNC Hardening (enabled by default in Windows 10) - try access an SMB share by the servers's FQDN and check that same name is in the server's smb.conf file. DNS aliases don't work.

  • Can you add a little explanation of how to accomplish the second paragraph? Thanks.
    – fixer1234
    Sep 16, 2016 at 16:08

Did you added a password for the user for samba?

Use command smbpasswd -a username to grant access.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .