8

As the subject says, I cannot get an XP guest to produce sound on my Windows 7 Ultimate 32bit host. Sound works fine in the host OS.

If I set the host audio driver to "Null Audio Driver" and the audio controller to ICH AC97, all appears to work, except no sound comes out the speakers. The Intel AC'97 Audio Controller shows up in my list of devices. As I understand it, that's what happens with Null Audio Driver. If you want sound, you need to select the Windows DirectSound for the host audio driver. If I do this, though, then when I start up the XP guest, it hangs with a dialog box titled "XPPro: Starting virtual machine" and the message "Starting virtual machine..." with a progress bar stuck at 0%. Here are the last few lines of my log file:

00:00:00.840 NAT: adding 24.116.2.50 to DNS server list
00:00:00.840 NAT: adding 24.116.2.34 to DNS server list
00:00:00.840 NAT: value of BindIP has been ignored
00:00:00.841 Audio: Trying driver 'dsound'.
00:00:00.936 Audio: set_record_source ars=0 als=0 (not implemented)

At that point the only thing I can do is kill the startup window. Setting the controller to soundblaster 16 lets the guest come up, but no audio device shows up in device manager or in the control panel app.

Any ideas how I can get sounds out of my guest OS?

UPDATE

I just finished installing VMware 3.0 and loading XP Pro there. Works like a charm. On the VBox forums, I was asked to submit a bug report, I guess there is an issue there.

2

I am running VirtualBox (3.1.2 when posted) on a Windows 7 Host, and my Windows XP Guest plays audio just fine. Here are my settings, I hope they help you:

Audio

  • Enable Audio: checked
  • Host Audio Driver: Windows DirectSound
  • Audio Controller: ICH AC97

To me it sounds like there is some sort of conflict with your host audio driver. Does this happen if you install a fresh new clean copy of Windows XP as a guest?

Any chance your could try to either upgrade your existing driver, or completely uninstall your audio device and reinstall it again?

One last thought, on the host, can you try changing the default audio device (Start -> Control Panel -> Sound) and try setting one of the other devices as the default? You may also want to go into the advanced settings for the device and reset the settings back to their defaults (most tabs have a button for that). Last, on the Advanced tab, there are some options for Exclusive mode. Ideally both should be checked, but try disabling them and see what happens.

  • i'll give it a try – DCookie Jan 28 '10 at 20:11
  • I cannot create a new machine - it hangs on the same error if I select Windows DirectSound. I'm using 3.1.2 as well.... – DCookie Jan 29 '10 at 2:40
  • @DCookie this sounds almost exactly like an audio driver issue with your host. – Goyuix Jan 29 '10 at 14:58
  • 1
    Well, it's selective then :-) VMWare has no problems (at least with audio, I haven't done much else yet). +1, and my thanks, for the response. – DCookie Feb 3 '10 at 0:50
  • @DCookie I was going to suggest you report this in the VirtualBox forums and log a bug in the bugtracker, but it looks like you may have already done this. Version 3.1.4 is currently in beta, maybe a future update will fix whatever is broken. – Goyuix Feb 3 '10 at 17:35
6

I had the same problem (host: Windows 7 64-bit, sound OK and guest: Windows XP SP3 32-bit, no sound).

What I observed:

In the configuration of the Virtualbox machine, I had:

  • Windows DirectSound Controller: ICH AC97 (default parameter)

In the guest OS (Windows XP SP3 32-bit), the sound driver was:

  • Intel AC’97 Audio Controller - SigmaTel Codec

That’s the problem! When you replace this driver to Intel 82801AA AC’97 Controller, the sound will work fine.

How can you change the driver?

Go to: Start ⇨ Control Panel ⇨ System ⇨ Hardware ⇨ Drivers, select the sound controller (SigmaTel), then Update driver ⇨ No web update, find the driver yourself ⇨ select Intel 82801AA AC’97 Controller

  • its works for me. force reinstall same driver. – Reinaldo Gil Jul 8 '14 at 4:09
1

I was also getting no sound with an XP guest Virtual box on a Windows 7 64 host but got it to work with the following settings: Host Driver: Windows DirectSound Controller: ICH AC97

Here's what I did:

  1. Tried every combination without success.
  2. Logged off the XP guest
  3. Selected Settings (Yellow Cog) in VM VirtualBox Manager
  4. Selected Audio in the left pain of the Settings window
  5. Ticked the Enable Audio check box
  6. Selected Host Audio Driver: Windows DirectSound
  7. Selected Audio Controller: ICH AC97
  8. Clicked the [OK] button
  9. Selected Start (Green arrow) in the VM VirtualBox Manager

Now inside the XP Guest:

  1. Selected [Start] > Settings > Control Panel
  2. Double left clicked on "Sounds and Audio devices" in the Control Panel
  3. Unchecked the Mute check box on the Volume tab of the "Sounds and Audio devices properties" window.
  4. Click the [OK] button.
  5. Played an .mp3 file and was able to hear the music.
1

While VM is stopped:

  1. Go to Settings in the machine drop down menu and click Audio
  2. Changed Audio controller to ICH AC97

After running Windows XP in Virtual Box

  1. Right-click My Computer and click Manage
  2. Click Device Manager, right-click Audio Hardware and click Update driver
  3. The Found new Hardware window opens. Click on Not this time > Choose Manually > Choose from list.
  4. Select Audio etc., then select Intel 82801AA AC’97 Controller

This solution worked for me. If it still doesn't work, it may be a conflict or compatibility issue.

0

My solution was pretty different.

I checked that the sound wasn't playing, then I shutted down the VM and change the Sound Hardware by IntelHD Audio. After restart, Windows would try to install the drivers but it can't because I needed the proper drivers downloaded.

Then I shutted down again te VM and change back the sound hardware to AC'97, and after reboot, the sound was playing. I've checked the drivers onto the device manager and it was the 82801AA AC’97 driver. It was installed by itself propertly :O

0

If I set up the virtual machine this way:

  • Power up my laptop (ASUS ROG G750JX)
  • Fire up VirtualBox
  • Create a Windows XP 32 bit guest (with audio disabled as a precaution)
  • Fire up the virtual machine
  • Go through the process of installing windows
  • Shutdown the virtual machine
  • Enable audio on the VM
  • Fire it up one more time (installing additions before or after this step is irrelevant)

When the desktop loads, a new hardware detected notification pops up, the Intel AC97 driver installs, and audio works fine; even if I restart the VM, audio still works.

However, if I shutdown the VM and close the VirtualBox main window, then audio won't work the next time I run VirtualBox.

I can fix this by restarting the laptop (the actual hardware). It seems VirtualBox may be doing something on its way out (perhaps some memory corruption of some sort or something when it shuts down) that prevents the XP guest's audio from working fine next time you try.

I don't know if this will work for others, but it's worked for me.

  • The first sentence of your main paragraph is over 100 words long. Please try to keep your sentences to a maximum of around 30 words. – Scott Mar 29 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.