3

I have a difficulty on updating my Windows 7 Ultimate SP1 through Windows Update!

  • [updated] Windows Update ends up with different errors 80070008 or 8007000e , 80072EE2 , C80003F3, and 80244019.

  • Windows Update Automated Troubleshooter reports (not fixed) :

    RootCause: RC_DataStore

    ErrorCode: 0x8024402C

Other things that I have tried so far :

  • Reboot (charger and battery removed)

  • Updating system/windows date and time

  • Checking Windows Update Options (Notify me when update available but do not download and install automatically)

  • Windows Update is using the latest agent (Windows Update Agent 7.6.7600.320)

  • System scanned for malware or virus - nothing found !

  • Drive C got 109G and Drive D got 29G of free space !

  • MY Windows copy is activated and genuine !

  • [updated] Already signed up for Microsoft Update to get "Update for more products"

  • [updated] I have checked Windows Update service in different times (seems no Windows server down)

  • Internet connection is okay - connected through a Home network with no proxy (Direct Access) !

  • I am using the system as the default Administrator !

  • Microsoft Security Essentials is up-to-date and is the only antivirus software is currently runing on my system !

  • [updated] System File Checker (sfc /scannow) found no missing or corrupted system files as Microsoft Support article kb/929833 suggested !

  • I have recovered my system with my different systerm restore images to fix this but to no avail !

  • [updated] Microsoft Fix it 50202 couldn't fix the problem !

  • [updated] System Update Readiness tool (kb/947821) couldn't help too !

  • After not getting result from above fixes, I reset Windows Update components manually as described by Microsoft Support - article kb/971058 - (even with aggressive mode - renaming SoftwareDistribution folder) but the problem still continues !

I really dont know what to do next ! Need your help ...

8
  • I had a similar problem, and it turned out that one of the older packages in the package manager was corrupt. I found an answer here that explained how to purge all related packages, so they would be re-downloaded, and after that everything was peachy. Sorry, I don't have a link anymore. (actually, this is how I came to superuser.com - I joined after that good advice!)
    – Aganju
    Dec 19 '15 at 15:21
  • 2
    0x8024402C = WU_E_PT_WINHTTP_NAME_NOT_RESOLVED (Same as ERROR_WINHTTP_NAME_NOT_RESOLVED - the proxy server or target server name cannot be resolved) So you have some network issues. Disable the AV suite/firewall Dec 19 '15 at 16:58
  • @magicandre1981 , I turned off my Windows Firewall (I have no other firewall software installed on my PC) but still my problem continues with error 8007000E and sometimes ends up with 80072EE2 ! What do you think ?
    – David
    Dec 20 '15 at 8:19
  • bro @Aganju I scanned my system files (sfc /scannow) and seems there is missing or corrupted system files : "Windows Resource Protection did not find any integrity violations." ! What do you specifically mean of packages in the package manager !?
    – David
    Dec 20 '15 at 8:42
  • 1
    80072EE2 = ERROR_INTERNET_TIMEOUT, so also network related. 8007000E and C80003F3 = OUTOFMEMORY errors. make sure this update is installed: support.microsoft.com/en-us/kb/3102810 and try again Dec 20 '15 at 19:09
1

Error code 80072EE2 means ERROR_INTERNET_TIMEOUT, so also network related. The errors 8007000E and C80003F3 mean OUTOFMEMORY. There is an issue in Windows Update, that the service consumes a lot of memory during scanning for updates. Looks you run into the issue. Microsoft fixed that issue with the following update:

Installing and searching for updates is slow and high CPU usage occurs in Windows 7
https://support.microsoft.com/en-us/kb/3102810

So make sure it is installed., to reduce the memory usage and improve installation speed.

1
2

ErrorCode: 0x8024402C

Causes:

These errors may be caused by any of the following issues:

Programs or processes that interfere with Internet communications ( as suggested by magicandre1981)

Resource issues on the computer

High Internet activity

Recoverable database errors

Source

Sounds like a firewall is blocking the connection.

2
  • Now my Windows Firewall is completely turned off and this is the only firewall software installed on my PC ! What to do next o_O ?
    – David
    Dec 20 '15 at 8:20
  • The problem still exists ... Need your help guys ... !
    – David
    Dec 20 '15 at 12:33
-1

I encountered error 0x8024402C updating an instance of SQL Server installed on my local development machine. I tried a few of the recommended things, including rebooting, turning off firewalls, and stopping/restarting WUAUSERV.

The machine I was using had a company installed Cisco Anyconnect VPN client for access to the corporate LAN. I was at a client site using their regular Internet connection, and therefore not using the VPN client. Although I was not trying to access the corporate LAN, I found that starting that VPN client, which then routed my Internet requests through that LAN, fixed the 0x8024402C error. I infer that Cisco Anyconnect was likely the culprit blocking access when it was not connected the way it wanted.

For what it's worth.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.