I'm running into trouble while upgrading my PC.

I've purchased and installed these products today:

Gigabyte GA-B150M-D3H
Crucial DDR4 Ballistix Sport 2x8GB 2400 CL16
Intel Core i5 6400
Scythe Mugen 4
Samsung 850 EVO 500GB

I installed them, booted up and everything worked fine. I was working from a clean windows 10 install (last summer I upgraded from Windows 7, then did a clean install). Because I wanted the Windows 10 install on my SSD, I used the same disc I used before, went on to install and I get this message (translated from dutch):

Can't install windows on this disk. The hardware might not support booting up from this disk. Make sure the disk controller is turned on in the BIOS menu.

When I click more info I get this (also translated): We can't make a new system partition of find an existing system partition. Read the log files from Setup for more information.

I've googled this and looked through some guides on installing Windows 10 on a SSD.

I've used Shift + F10 to open command prompt. With the diskpart commands I've cleaned, converted to MBR and back to GPT, I've reformatted to NTFS. At some point when the SSD was just unallocated space, I pressed 'new' and it made the 4 partitions that it should with a GPT system. I selected primary and installed Windows. The installation finishes without a problem, the system reboots and then I get a black screen with the message 'reboot and select proper boot device or insert boot media in selected boot device and press a key'.

After reinstalling windows once more and retrying many times I've also encountered a blue screen with a header: "Recovery" Your PC/Device needs to be recovered. Can not launch the OS because a needed file is missing or corrupted. File: \Windows\System32\winload.efi Errorcode: 0xc0000225.

I've googled both messages and the error code. I can not find a solution. I'm really hoping somebody can give me a hand. I've tried reinstalling windows to my normal HDD. I get the same problems now. No idea why. I ended up getting an old HDD from a mediaplayer, installed windows on that, and there's no problem (so it's not the install files).

If anybody has any idea's I would love to hear them. I'm all out...

3 Answers 3


The first thing to do is to make sure that the SSD is attached correctly, with all cables plugged in properly.

The second thing you need to do is make sure that The SSD is in AHCI mode and not IDE mode. This one catches most people out. Windows 10 is extremely picky about HDD/SSD modes. You can adjust this in the BIOS.

Third thing is to check the media. This step is crucial, as some Windows media can become corrupt and refuse to use a SSD.

From a working Windows install, visit this page Windows 10 Media Creation Tool

Download the tool and create proper media. Since you've upgraded once already, you can use the Windows 10 media to install and skip the product key, as your system should already be authorized by MS.

Windows 10 Skip Product Key

That should allow Windows to install. Install it as per usual, and you should be golden

  • Hi, Thanks for your reply! The SSD is attached correctly. And my MB is in AHCI mode. I found the option in the BIOS and there isn't even another option. I will try to create a new windows installer. I'll let you know what happens. Thanks again.
    – Erik
    Dec 20, 2015 at 9:24
  • Ok, so I've tried, made a new install media with the suggested tool from Microsoft. No dice. Same deal: I boot UEFI, I let the installer create the 4 GTP partitions. I select primary, install, everything seems to go ok. Then reboot right back into the installer (at the start, like nothing happened). If I remove boot media, I get a black screen with the message: Reboot and select proper boot device or insert Boot media in selected boot device and press a key. No idea what to do now.... :(
    – Erik
    Dec 20, 2015 at 10:17
  • @Erik sounds like Windows isn't installing a bootloader. do you by chance have any other drives plugged in whilst installing Windows?
    – td512
    Dec 20, 2015 at 19:59
  • Honestly, if it installs fine but at the end nothing is changed, it sounds like you may have a faulty SSD. Nov 1, 2016 at 4:25

It wasn't exactly clear, but both the original install, and the subsequent install created by Windows 10 Media Creation Tool, you were burning a CD and using it for the install? (I'm just asking, to contrast it installing from a USB flash)

In reading the manual for the BIOS setup (page 29) for the Gigabyte GA-B150M-D3H, http://download.gigabyte.us/FileList/Manual/mb_manual_ga-b150m-d3h(ddr3)(gsm)_e.pdf

it says:

Boot Option Priorities

Specifies the overall boot order from the available devices. Removable storage devices that support GPT format will be prefixed with "UEFI:" string on the boot device list. To boot from an operating system that supports GPT partitioning, select the device prefixed with "UEFI:" string.

Or if you want to install an operating system that supports GPT partitioning such as Windows 7 64-bit, select the optical drive that contains the Windows 7 64-bit installation disk and is prefixed with "UEFI:" string.

Hard Drive/CD/DVD ROM Drive/Floppy Drive/Network Device BBS Priorities

Specifies the boot order for a specific device type, such as hard drives, optical drives, floppy disk drives, and devices that support Boot from LAN function, etc. Press on this item to enter the submenu that presents the devices of the same type that are connected. This item is present only if at least one device for this type is installed

What order do you have in those two groups in the BIOS? I'm wondering about UEFI boot vs legacy boot in your bios.

Also: remove the CD or USB key before the reboot after install (power down/remove/power up)

Also: what BIOS version do you have on the GA-B150M-D3H? The latest bios on http://www.gigabyte.com/products/product-page.aspx?pid=5491#bios is F21 from 12/12/2016

  • Another thing to try/report is to hit F12 to get the extended boot list during reboot, and select the SSD. Do you have any other SATA or USB devices (like a USB card reader or other SATA drives?). I suppose the optical drive is on SATA. Jan 29, 2017 at 19:40

You need to create a partition that is smaller than the default. Looks like a corrupted drive -try 1 gb less and see if it works. Worked for me after nothing else worked on a crucial 750 gb drive.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .