0

I've got a strange problem with my SSD. I've installed my system on it (windows 10) and it was working fine for some time (aside from occasional freezes at the start of a system). Now when I boot my PC, I can not access some of the things on my main C: drive (SSD) where Windows is installed. For example, when I right-click on the desktop and I choose display settings, a message pops up and tells me that there is no program associated with this task.

I can access files on my SSD - pictures etc...

I tried to change AHCI to IDE in BIOS, but then I couldn't boot up my PC due to drive being inaccessible.

One more thing - when I try to run some program installation from my other drive (HDD), it just freezes.

Any suggestions? I'm desperate.

  • It's possible that your other non SSD drive has stopped working and is causing your problems, have you tried disconnecting it? Also do you have Samsung Magician installed as that may highlight any issues with your SSD. – Piers Myers May 27 '16 at 17:08
  • `I tried to change AHCI to IDE in BIOS, but then I couldn't boot up my PC due to drive being inaccessible. That is what is supposed to happen. I you change the disk controller from normal AHCI to legacy mode and then boot windows which is configured to look for its files on an AHCI disk then it will not find its disk or files and boot will fail. Leave this on the AHCI setting. – Hennes Aug 17 '16 at 16:03
-1

I can confirm that this problem also exists in my Samsung SSD 850 EVO mSATA in a Dell Precision M4800

I have been looking to solve this problem for two months. I had discovered that the problem was less frequent when the power supply was plugged. When the computer was operating only from battery, freezing occured almost instantly after loading the windows welcome message.

The cause is that EVO850 does not support Intel Rapid Storage LPM, and when the OS is requesting Low power operations, the system freezes.

There are some people saying that a solution is disabling AHCI from BIOS, working only under ATA compatibility mode. And it is true that this works, because ATA has no Low power management features. But the right thing to do is to disable the LPM management from Intel Rapid Storage.

There are two options to do this:

To be sure that this works, just do both!!

And if you are worried about disabling LPM, just don't!! This is only useful for mechanical hard drives. SSD drives have a very reduced power consumption and do not really get any benefit from LPM.

  • Please quote at least the most important parts of the solution(s) you link to. If these pages disappear your answer will be hardly useful. – Kamil Maciorowski Mar 9 '18 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.