7

I enabled virtualization in the bios yesterday and the virtual machine worked yesterday. Today, I double checked in the bios and virtualization is still enabled. But the virtual machine is giving me this error when I tried to start it up:

Failed to open a session for the virtual machine Ubuntu 15.04.

AMD-V is not available (VERR_SVM_NO_SVM).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

What's causing this, and what do I do?

My motherboard is a Gigabyte GA-78LMT-USB3

My CPU is an AMD FX-6300 3.5GHz 6-Core Processor Black Edition

Update: After installing a 32-bit version of Ubuntu on the virtual machine, it worked fine. However, that still doesn't explain why VirtualBox doesn't detect that I have AMD-V, I tried running ubuntu on vmware and that tells me that I have to turn Hyper-V off, so my virtualization is definitely on, it's just that virtualbox does not detect it.

Update 2: Ubuntu launches, but it keeps flickering non-stop; this means that VirtualBox is not detecting my Hyper-V.

Update 3: Hyper-V was installed on the system, Hyper-V apparently causes a conflict between other virtual machines, I'm turning this off now and letting windows restart.

Update 4: IT WORKS!

  • Hope, other users will quickly provide you a solution over here. – MWiesner Dec 21 '15 at 21:17
  • @MWiesner Hey again, I hope so too; really need this to be solved. – Dominik H Dec 21 '15 at 21:17
  • 1
    Do you have any other hypervisors running? – Ƭᴇcʜιᴇ007 Dec 21 '15 at 21:22
  • @Ƭᴇcʜιᴇ007 nope, only virtualbox, if that's what you're asking? – Dominik H Dec 21 '15 at 21:24
  • I have that issue sometimes, and a reboot helps. for some reason, something seems locked from the previous run. I guess you had that idea already; if not, try reboot to clean the locking of the AMD-V – Aganju Dec 21 '15 at 21:27
4

Make sure Hyper-V is disabled.

This is the command you should run in cmd.exe as an administrator

dism.exe /Online /Disable-Feature:Microsoft-Hyper-V-All

Full instruction set is listed here

http://www.poweronplatforms.com/enable-disable-hyper-v-windows-10-8/

  • Welcome to superuser and thankyou for your answer, but it may have already been in the updates:- Update 3: Hyper-V was installed on the system, Hyper-V apparently causes a conflict between other virtual machines, I'm turning this off now and letting windows restart. Update 4: IT WORKS! – mic84 Apr 24 '17 at 8:44
  • 1
    @mic84 It wasn’t an answer, however. Answers go in the answer section, not in the question. – Daniel B Apr 24 '17 at 8:50
  • Hi @mic84 and DanielB I really appreciated the op's questions because it was a similiar error... And apparently a lot of people trying to run VB or Gennymotion have the same issue. The obscurity wasn't with my Bios (which I updated) or settings which I kept trying to adjust... or running in 32 bit mode for certain aspects like the OP suggested... But alas JUST make sure Hyper-V is not running which is a default setting since at the very least the Windows 10 Creators update has been issued. That is why I felt an answer with just Hyper V was adequate and hope it helps more people – Christian Matthew Apr 24 '17 at 14:02
0

When you enabled Virtualization in your BIOS settings, the reason why your Virtual Machine worked perfectly fine is because the BIOS setting didn't actually kick in until you powered off your PC and powered it back on.

Assuming your guest OS is 32-bit, LongMode must be disabled. In some cases it isn't, which is just bad. To fix this for a particular VM, open Terminal and enter:

VBoxManage modifyvm <vmname> --longmode off

Don't forget to replace <vmname> with the name of your virtual machine.

For some reason your issue only comes up when hardware assisted virtualization is enabled in the BIOS. Anyway, if this does not fix the issue, then I would put my money on your CPU or motherboard not providing a fully compatible hardware virtualization implementation, in which cause you'll just have to disable the BIOS feature.

Incidentally you might want to update your question with more details about your motherboard and CPU, that may give us more clues as to what's going on.

  • I will update the information now. And just a quick question: If instead of rebooting, I turn the pc on and off; would this make a difference rather than doing a normal reboot where my pc remains on? – Dominik H Dec 21 '15 at 21:53
  • Also, I would like to note that the Guest OS is 64-bit, BUT has been forced to run in 32-bit mode as Virtualization is apparently "not available" – Dominik H Dec 21 '15 at 21:56
  • @DominikH When you change Virtualization BIOS setting, the requirement is that you power down the PC for the setting to take effect. Just rebooting is not enough. – misha256 Dec 21 '15 at 22:02
  • @DominikH Is your HOST operating system 32-bit or 64-bit? – misha256 Dec 21 '15 at 22:02
  • ahh, now that's something, cheers for letting me know. I will actually power down the system and then try that again! – Dominik H Dec 21 '15 at 22:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.