1

I have a Gestetner printer, installed via CUPS and working under other pdf readers like Evince.

However, with Adobe Reader, I get an error:

lpq : Gestetner : unknown printer

lpstat -a lists the printer as accepting requests, however lpr -P Gestetner_MP7500 yields again the unknown printer error.

One workaround I have found is installing cupsys-bsd, which removes lpr. The only annoyance(!) is that it crashes now when I select duplex and click OK.

I am running Debian by the way.

1 Answer 1

1

I know that maybe you'd already tried this solution, but I remember myself searching for a similar solution the last year, and it tooks me a couple of weeks to figure it out...(yes, I'm that kind of n00b, guys! :D).

So, have you tried to browse your CUPS webservice?

Hope that helps.

Regards

3
  • 1
    Good suggestion. Most of my CUPS problems have been fixed by this method.
    – Iain
    Commented Jan 28, 2010 at 17:59
  • Yes, actually the web service is the only tool I use with CUPS. The problem is with the Adobe Reader I guess, however as far as I understand, cupsys-bsd provides its own lpr binary instead of the package lpr; so that should be preferred. Why Debian by default installs lpr is beyond me, however.
    – ustun
    Commented Jan 29, 2010 at 15:03
  • See apt-file search lpr | egrep '/lpr$' Both provide lpr binaries I guess. Actually, the new package name seems to be called cups-bsd, not cupsys-bsd which has become an obsolete transitional package.
    – ustun
    Commented Jan 29, 2010 at 15:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .