For a few days I have now the problem with StackOverflow and other StackExchange websites (didn't notice it on any other website yet) that I see advertisements from DNSUnlocker. It took a while to realize that this is actually some sort of malware. It only happens in Chrome on my MacBook Air (running El Capitan). It doesn't happen on:

  • Safari
  • Firefox
  • Chrome in incognito tab

So only normal chrome. I've tried removing Chrome completely, based on this answer: https://superuser.com/a/318205/236270 and reinstalled it again. Even though I didn't set up sync just yet, I already had the problem.

Again, the problem occurs only on my macbook and only in "normal" chrome tabs (not in incognito).

After that I've tried Malwarebytes, MacKeeper and Kaspersky but neither were successful in finding any malware on my computer (except now I also need to get rid of those 3 - obviously useless - applications).

I barely touched my macbook the last days and couldn't find anything suspicious installed during the last week, neither in Applications, nor in Chrome Extensions. (Obviously - reinstalling chrome completely took away the extensions anyway).

I do have some other google software (picasa, music, drive) installed, which I didn't reinstall yet. I also couldn't find (and didn't really expect to) the virus as an extension in safari or firefox. Any other ideas how I could get rid of it? (Nobody else in my network has that problem, and I didn't notice the problem anywhere else, but stackoverflow/stackexchange)


As mentioned in the comments, I've checked network settings and they seem ok. I'm using Google's DNS servers and

Update 2

It seems I'm not the only one with these kinds of problems: https://meta.stackexchange.com/questions/267846/dnsunlocker-intrusive-ads

This guy had pretty much the same problem as me: http://blog.voltagex.org/2015/10/07/malvertising-on-my-stackoverflow-its-more-likely-than-you-think/

Unfortunately (or luckily), those ads are gone now. For the next time they'll show up, I'll try pinging StackOverflow to see if the IP Address has changed.

  • The issue may be related to altered network settings, try the steps in the article here: macsecurity.net/view/104.
    – James P
    Dec 22, 2015 at 16:33
  • Sry, forgot to mention, dns settings seem ok as well, I'm using and but I'll check the rest more thoroughly again.
    – peter
    Dec 22, 2015 at 16:47
  • Did you try the Reset to defaults option in the Chrome options dialog?
    – James P
    Dec 22, 2015 at 17:24


You must log in to answer this question.

Browse other questions tagged .