5

Since the last Yosemite update (and by extension, El Capitan), VLC doesn't go on a second desktop anymore when I press the fullscreen button on the upper left of the window as it used to do :/

Thank you for your help :-)

5
  • It ought to fullscreen on whichever screen it's currently on
    – Tetsujin
    Dec 22 '15 at 18:04
  • I know, and I'd like it to open on a second screen
    – ggrelet
    Dec 22 '15 at 18:08
  • then drag it to the 2nd screen before you fullscreen it
    – Tetsujin
    Dec 22 '15 at 18:13
  • Haha, I want it to be automatic, otherwise that's easy Thank you for your help
    – ggrelet
    Dec 22 '15 at 18:14
  • It ought to be, the second time you do it
    – Tetsujin
    Dec 22 '15 at 18:16
5

Having the same weird issue here. What has proven to kind of work for me on El Cap is using the green fullscreen button on the top left corner first (creates basically a black desktop with VLC controls in it) and then CMD+F twice when in fullscreen VLC (puts the content inside and the controls on top). To get it back to windowed mode CMD+F, switch to another Desktop, back to fullscreen VLC and click the green fullscreen button again... A bit fiddly and certainly annoying. it seems like the VLC interface doesn't respect the way Mac OS handles fullscreen right now. Anyway, I hope that workaround works for you. You could still create a second desktop like the commenters before me suggested, would probably be easier.

3
  • 11
    I just found the fix to this. Basically you just have to go in to the settings and select "show all" in the bottom left, expand "Interface", expand "main interfaces", go into macosx and select "use native full screen mode" (or something along those lines, using different localization here). Feb 5 '16 at 20:27
  • 1
    "use native full screen mode" is the right answer
    – snowbound
    Jun 26 '16 at 6:08
  • @justsomerandomdude could you answer properly (i.e. not in a comment)? So that I can mark your answer as the accepted answer.
    – ggrelet
    Apr 15 '20 at 17:25
3

Just go into Preferences, click the video tab and in the Fullscreen video device choose the screen you want VLC to be in.

screenshot

2

@justsomerandomdude has provided the good answer to this problem. Quoting them:

I just found the fix to this. Basically you just have to go in to the settings and select "show all" in the bottom left, expand "Interface", expand "main interfaces", go into macosx and select "use native full screen mode" (or something along those lines, using different localization here).

1

Head over to Videos -> Full screen video devices and select resolution of the screen you wish to maximize to.

1

Go to video settings > use native fullscreen mode

0

Go to preferences, click on video tab and unselect the Black screens in Fullscreen mode. See this screenshot

0

As others pointed out, @justsomerandomdude has already provided the answer. This answer contains a screenshot displaying the solution.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.