3

After update 1511, all my VMs broke as far as networking goes. The switches did not appear anymore in Network Adapters, but were still listed in the Hyper-V Switch Manager. I deleted the switches from here but when trying to recreate, I get this error below. It happens for all 3 types of switches. I've tried the nvspbind uncoupling, removing/reinstalling the Hyper-V feature, and tried to scrub my registry for the offending adapter.

enter image description here

I still see a Hyper-V switch listed in nvsp for some reason, but it does not appear anywhere else, including device manager. Is there a way to get rid of it from here, in case it's blocking creation of new switches?

enter image description here

6
  • 2
    And microsoft wonders why IT Pros want to block automatic updates.
    – Colyn1337
    Dec 22, 2015 at 20:15
  • Have you tried refreshing the system?
    – Jim B
    Dec 22, 2015 at 20:23
  • 1
    Try removing it via PowerShell. ie: Remove-VMSwitch -Name "Int" Dec 22, 2015 at 21:27
  • @Colyn1337 No they don't, Microsoft provides a system that allows IT to stage updates to limited computers before a general release to the domain and is free, you just have to check the box on a windows server. Windows Server Update Services Dec 22, 2015 at 21:33
  • Jim - have not tried refreshing the system, leaving that as a second to last resort at this point. I'd rather roll back the update than refresh, if anything.
    – Agent
    Dec 23, 2015 at 17:23

1 Answer 1

0

I tried almost everything under the sun to get it working, from updating all drivers, a wireless adapter, reg keys to delete all switch entries, etc. Also decided to uninstall my physical NIC driver as a semi-last resort based on a troubleshooting article to see if reinstalling would help. Well, this completely destroyed any chances of fixing the issue. I could see the NIC in Device Manager after reinstalling, but it would not appear in Network Connections at all. I uninstalled several apps that could have been interfering with it, like VPN apps, but even after that no luck.

I decided to go with my last resort, a roll back of the update. I was a bit leery of this option, as there's always the chance updates/roll backs could fail and require a clean reinstall of everything. Decided to go with it and prayed. Roll back took about 10 minutes. Once the PC came back up, everything appeared to work normally, including my Hyper-V networking. I then checked the option for Defer Upgrades, as I'd rather not deal with new update bugs.

Hopefully this helps anyone else with similar issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.