A few days ago my macbookpro touchpad stopped working with windows 10.

My attempts to fix the issue:

a) Looking at the device manager, I can see that the touchpad drivers (there are 2 of them for some reasons) are indeed complaining. Upgrading or 'Removing + scanning for new H/W' invariably produce the same result.

Windows found driver software for your device but encountered an error while attempting to install it. [...] Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)

b) I also tried to delete the touchpad drivers via the Programs and Features.

Windows Driver Package - Apple Inc. Apple Trackpad (07/13/2009 3.0.0.1)

and it fails because it cannot find the .inf file in charge if uninstalling the driver. Looking at it closely the path between what the device driver installation wizard is telling you and what's on the system is indeed slightly different. The Device Driver Installation Wizard says : ERROR: File 'C:\Windows\System32\DriverStore\FileRepository\aapltctp64.inf_amd64_neutral_99bcf785d5d9575a\aapltctp64.inf' not found It seems that I don't have a _neutral variant of the path. In other words the closest path I have to this is C:\Windows\System32\DriverStore\FileRepository\aapltctp64.inf_amd64_99bcf785d5d9575a\aapltctp64.inf

What I changed recently

The big changes that I had done this week was to install the latest windows 10 big update (dated Novembre 2015) which got postponed until now as it continuously failed until I forced a re-download (but that's beside the point).

The second big change was to update iTunes to latest version along with my iPhone to the latest iOS 9.2 (I believe this guy also tend to update drivers.. but I might be wrong)

Oh and last but not least, I am stuck with bootcamp 3.1 as it refuses to install the latest 3.2 as I am using a fairly old MacBook Pro (15-inch, Mid 2010). So unfortunately, I cannot install the latest drivers :(


Edit 15/01/2016 :

I didn't realize I could get specific driver events from event viewer. This is what I get :

Event Id=43, Source=Kernel-PnP

Device USB\VID_05AC&PID_0236&MI_01\7&34195f1f&0&0001 could not be migrated.
Last Device Instance Id: USB\VID_24EA&PID_0197\6&2B3428FF&0&3
Class Guid: {745a17a0-74d3-11d0-b6fe-00a0c90f57da}
Location Path: 
Migration Rank: 0xF000FFFFE000F122
Present: false
Status: 0xC0000719

Event Id=20003, Source=UserPnP

Driver Management has concluded the process to add Service applemtp for Device Instance ID USB\VID_05AC&PID_0236&MI_01\7&34195F1F&0&0001 with the following status: 0.

Event Id=20001, Source=UserPnP

Driver Management concluded the process to install driver applemtp64.inf_amd64_54543ed2cd13e906\applemtp64.inf for Device Instance ID USB\VID_05AC&PID_0236&MI_01\7&34195F1F&0&0001 with the following status: 0x0.

So, it looks like windows is trying to "migrate" these drivers but is failing in the attempt because it cannot find them ?

Any clues on what I can try next ? Who do I need to contact ?

up vote 4 down vote accepted

I ended up asking on microsoft answers forum and a support engineer gave me the perfect answer.

Her answer was as follow :

The issue could be because of incompatible or corrupted drivers on the computer. Please follow the below steps to resolve the issue :

  • Open the Device Manager.
  • Tab once, then go down with the arrow keys to the list of unknown devices. It should say Touchpad on atleast one item.
  • Open up the properties for the Touchpad device, and try to install a driver from local disk (do not search online, that won’t help).
  • Choose USB input device as the driver, do not use the apple driver just yet. After the installation is finished, your touchpad will work.
  • After installing the USB driver you can perform the same steps, but pick the Apple driver. After the installation is complete, your touchpad will work as expected.

And it does !

  • All I had to do was disable and re enable the driver. It worked perfectly. – Vahid Amiri Mar 3 at 22:30

I had exactly the same problem after applying the November update on a 32bit windows 10 installed on a late 2011 MacBookPro. I was able to get rid of the November update by using the uninstall option for the update in "Programs and Features". What I found is that after the update, the Apple Touchpad driver version was something like 3.0.2, while the previous driver version was 4.0.0.1. It appears that the update somehow installs an older, incompatible version of the Touchpad driver.

  • It appears that the update somehow installs an older, incompatible version of the Touchpad driver Do you think so ? That would be so strange. Where would it get it from ? Also, can someone explain why the driver changed path from C:\Windows\System32\DriverStore\FileRepository\aapltctp64.inf_amd64_neutral_99bcf785d5d9575a\aapltctp64.inf to C:\Windows\System32\DriverStore\FileRepository\aapltctp64.inf_amd64_99bcf785d5d9575a\aapltctp64.inf – DarkUrse Dec 28 '15 at 13:42

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.