0

Eh, I bought this USB flash drive 1 day ago to make a bootable USB flash drive for Ubuntu. After writing the iso a couple of times, I still can't boot the USB flash drive (maybe UEFI problem) but now this USB flash drive has problem itself.

When I connect, it says 'you need to format it...' but I can't format it, it shows error. I tried PartitionGuru tool and even that tool crashed and couldn't format it.

So my USB flash drive done :( ?

EDIT: It was a Kingston 8 GB USB flash drive but now it shows only 8 MB

  • It does sound like it has failed. Time to get the shop to swap it for another one, perhaps from a different manufacturer. – Andrew Morton Dec 23 '15 at 18:00
  • have you tried to delete or create a partition first – jet Dec 23 '15 at 18:07
  • @AndrewMorton I don't think that shopkeeper would change a $4 stick e.e but first I want to be completely sure if its dead or not – Waleed Dec 23 '15 at 18:41
  • @Waleed If they get a lot of returned ones, they may stop selling them. I suggest using the refund to buy one from a more reputable manufacturer in the same shop - the shopkeeper is likely to be more amenable to that. – Andrew Morton Dec 23 '15 at 19:11
  • @AndrewMorton LOL! I exchnged it with another USB but with 4GB and I tried to use UnetBootIn/UUI to make it bootable but now same thing happened. First it wont boot, second, it won't format. Should I exchange it again or this time its my fault? – Waleed Dec 27 '15 at 3:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.