0

A few days ago I played around with all the Intel services that are installed on my system recently. For example management engine and heci server. First I disabled every single Intel service as well as quite a few others of which I thought I wouldn't need them... then my Windows wasn't able to boot up again (not even in safe mode). So I did a system restore, which still didn't fix the issue and then I just used an external registry editor to enable all the services again. So all Intel services are running again, potentially even more than before...

Now I was just trying to hook up a 1080p screen to my notebook and it didn't allow me to run it with its native resolution. I sure had the option for 1920x1080, but but every window was scaled in a way that it just looked like 1366x786 (native resolution of my notebooks screen)... really weird! I've never seen that before!

So I tried to update my graphics drivers. The drivers that the manufacturer of my notebook provided via their website, but they straight up do not work. The driver for the dedicated graphics card (AMD Radeon HD 7670M) just failed during the installation. So did the official driver from the AMD site.

And the Intel HD 4000 driver of my notebook manufacturer failed to install, too. Even worse: The driver that windows 8.1 itself provided me by updating the driver through the device manager caused a bsod during the installation. And after uninstalling the driver of the intel hd 4000 thing in the device manager and rescanning for changed hardware, windows again installed the bsod causing driver, only this time I wasn't able to boot anymore, forcing me to do a system restore.
The Intel HD driver from the Intel site didn't work either. enter image description here
I found the following in the event logger:

The UAC File Virtualization service failed to start due to the following error: This driver has been blocked from loading

The Intel(R) Serial IO I2C Controller Driver service failed to start due to the following error: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

The computer has rebooted from a bugcheck. The bugcheck was: 0x0000003b (0x00000000c0000005, 0x0000000000000000, 0xffffd00181533400, 0x0000000000000000). A dump was saved in: C:\Windows\MEMORY.DMP. Report Id: 122415-4984-01.

I have absolutely no idea what could be causing this and a Windows reinstall is definitely not an option.
Do I need an older version of the Intel HD driver? If so, are there trustworthy sources?

System: OS: Windows 8.1 Pro x64 with WMC
Notebook name: HP Pavilion G6-2348SG
CPU: Intel® Core™ i7-3632QM 3rd gen (2.20 GHz, 6MB Intel® Smart-Cache) ; up to 3.20 GHz with Intel® Turbo Boost
Screen: 39,6 cm (15,6“) 1366 x 768 Pixel, 16:9 HD BrightView LED-Display
GPU: AMD Radeon HD 7670M (2 GB DDR3 dedicated)
RAM: 6 GB DDR3 1600 MHz, max. 8 GB
SSD: Samsung 840 EVO, 250GB
Network: WLAN 802.11 b/g/n, Fast-Ethernet
I/O: VGA, HDMI, 2x USB 3.0, 1x USB 2.0, 3.5 jack for mic, 3.5 jack for speakers

  • 1
    It's an HP - it' may be locked to their drivers, quite a few lappy makers do that, HP, Sony, Toshiba etc. Try HP for updates. – Tetsujin Dec 24 '15 at 12:24
  • Both your drivers can be found on the HP support page for your specific model and OS. support.hp.com/us-en/drivers/selfservice/… – Moab Dec 24 '15 at 18:07
  • The Graphics drivers are dated Dec 9th, 2015, so they are the latest at this point in time. – Moab Dec 24 '15 at 18:08
0

The correct Intel graphics driver for your machine is listed here. I would recommend downloading the ZIP version, extracting it, and using these instructions to manually install the driver. If this fails, there is something going very wrong somewhere.

As for your AMD graphics driver, I would again recommend trying to reinstall it from the AMD website, using the instructions above to try and manually install them.

These drivers, although when using the installer will recommend using the ones from your manufacturer, should definitely work and be better than the almost always severely outdated ones on the manufacturer site. There is no 'technical' reason you cannot use the drivers from Intel/AMD directly, however manufacturers will usually enforce their drivers for support reasons, as they're tried and tested on the machine and it takes a huge level of variation out of any queries they may get.

  • Please don't use non-manufacturer drivers unless you have no other option. It is preferred to get your drivers from HP, because they have been adjusted for your hardware. Getting your drivers from elsewhere, for example Intel, can cause issues because they don't take your hardware into account. Always fun when you need to diagnose webcam output being flipped because the non-manufacturer driver didn't know that it was mounted upside down... ;-) – Tamara Wijsman Jan 3 '16 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.