13

I am running Windows 10 Pro, build 10586, on a Lenovo T-520. Fairly recently a behaviour has appeared, where the screen locks, and goes blank, after about 2 minutes of not using the PC.

I have checked all power settings, every single one, and nowhere, when on mains, is the PC set to hibernate or sleep after a time shorter than 2 hours.

What could be causing this very quickly triggered screen lock? To unlock, I must use the keyboard or wiggle the mouse to show the lock screen, then click the mouse to show the password input.

20
8

After searching around for a while I stumbled across this:

"I think I finally found the problem. There's a setting called "System unattended sleep timeout" However, in Windows 10 it does not show up in the Advanced Power Settings.

I had to add it through a registry edit from here (the Windows 7 regedit works on Windows 10) http://www.sevenforums.com/tutorials/246364-power-options-add-system-unattended-sleep-timeout.html

So far it has not gone to sleep after two minutes when I wake it with my mouse.

So, it looks like a Microsoft problem, not hardware." by CaesarMagnus

After changing the registry using the link he provided, I was able to change that setting, and it fixed my issue. Hope that helps.

0
5
+50

I know this is strange, but do you happen to have any finger print drivers installed? I read an article online, saying the Lenovo finger print driver has been causing some issues with the power settings.

2
  • Ooh, who would have though of that. I do, I'll look into that, thanks.
    – ProfK
    Jan 18 '16 at 21:08
  • I had to award the bounty due to the time limit, and this is the only answer that raises a question I have not already investigated and found to not be the cause of the problem.
    – ProfK
    Jan 21 '16 at 5:49
0

I dont have enough reps to comment so adding as an answer.

I am not quite sure of the issue, but just wanted to add my cents. Have you checked the "Choose what closing the lid does" option in Power settings..? See screeenshot: http://imgur.com/7gVmuLP

Hopefully this gives you some idea.

2
  • I have checked that. It should do nothing with mains power on.
    – ProfK
    Jan 18 '16 at 21:07
  • @ProfK Good, did you try to put on "do nothing" for both and see if the problem still occurs?
    – Hastur
    Oct 12 '16 at 12:18
0

This is a bug/feature of the Lenovo Battery Safer Software. Try to uninstall it or configure it(i dont know if there is an option for it). I'm working with several Lenovo Notebooks(of any kind and any Model) on my work and we noticed some problems with the built in lenovo software.

0

Just to throw in another symptom, this has started happening to me, but only when the computer is under load. I can fairly consistently reproduce by setting off a render in Premiere, and watching a YouTube video in Chrome at the same time.

Inactivity doesn't matter, I can be in the middle of typing when it happens. Computer locks itself and goes to sleep. I then have to press the power button for it to come back up, and it just continues from where it was.

I'm guessing it's some kind of overheat/overload protection kicking in to keep my laptop from melting. The only solution I've found is to just leave the computer alone while doing intensive tasks.

-1

Your organization requires you to...

This confounded me for a long time; I had tried everything in every troubleshooting guide and more.

Turns out it was because I linked my Microsoft (company, eg. @microsoft) account to my personal device.

To fix this, just go to Settings > Accounts > Access work or school and remove your work account.

Must have some sort of secret lock-computer-after-1-minute policy to protect your extremely important emails from, idk, your dog? Your wife? (I know, I know, a malicious Apple spy at the cafe.)

They could have at least had a message show up in the power settings...

-2

I can help fix your problem, just follow these steps and you will be able to shut your laptop lid and the screen will not turn off.

  1. Right click the battery in the bottom left and then click "Power options"
  2. On the option you have active, click "Change plan settings"
  3. Click "Change advanced power settings"
  4. Find where it says "Power buttons and lid" then click it
  5. Click "Lid close action"
  6. Change "On battery:" and "Plugged in:" to "Do nothing"

Link to what it might look like: http://i.imgur.com/QO0P3A5.png

This should make it so when you close your laptop lid, the laptop screen will stay on and it will not fall asleep like it usually does.

Have a good day!

1
  • 1
    Welcome to Super User! On this Q&A site we try to provide good answers to questions people ask. Part of providing an answer is fully reading the stated question. In this case, the question states that OP already checked all power settings. As such your answer does not contribute any useful information that might help in resolving this issue. Please update it to suggest a possible solution that hasn't been posted yet, or remove the answer.
    – Cas
    Oct 12 '16 at 11:43
-2

Go through this link to solve your problem:

https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/Machine-always-goes-into-standby-mode-after-1-min-of-being-idle/ta-p/414093

1
  • Link-only answers are not helpful. Please edit your answer, and include all relevant information, be sure to quote and cite any sources you might use for that information.
    – Ramhound
    Jun 30 '17 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.