1

I recently attempted to install Windows 10 as a dual boot alongside Ubuntu 14.04. I used WinUSB to create a bootable drive. I booted into the USB, but when I attempted to select the empty NTFS partition I created for Windows, I received the following error message: "Windows cannot install to this drive. The drive is of the GPT partition style." I know that Windows requires a GPT drive when the system boots in UEFI mode, so I've come to the conclusion that mine was not. However, when I disabled Legacy support in the BIOS menu, the USB with Windows on it disappeared from the boot menu. I know my motherboard, an ASUS M5A97 R.20, is UEFI-capable, so what is causing this problem?

  • 3
    Your firmware is UEFI-capable, but your bootable USB is not – WinUSB can only create BIOS-bootable USB disks. On Windows, Rufus or the official Microsoft's USB tool can create UEFI-capable ones. Someone else might know how to do that on Linux. – grawity Dec 24 '15 at 19:14
  • 1
    A similar question has been been answered at askubuntu.com/questions/395879/…. – DrMoishe Pippik Dec 24 '15 at 19:28
  • That's odd considering that there's a folder in my USB called "efi". – evandewey Dec 24 '15 at 19:36
  • 1
    I can't speak to WinUSB's capabilities, but more than an EFI directory is required to boot in EFI mode. Specifically, the filesystem must be FAT and the boot loader file itself must be present -- normally that's EFI/BOOT/bootx64.efi. There are many other things that could cause problems, too, some of them system-specific. Overall, I agree with grawity: You should try re-creating the USB drive with another tool, or at least check to see if the tool you use has options relating to EFI support. – Rod Smith Jan 4 '16 at 22:59
  • I did using Rufus, worked like a charm. Thanks everyone! – evandewey Jan 5 '16 at 1:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.