1

The bounty expired yesterday, but I will not be awarding it as no answer has solved my problem. Would anyone like to try to help? I just want to set up workgroup (not homegroup, as they require passwords) or other simple method to share drives from one PC to a few others.

[Latest] I turned off all network sharing on both PCs, then turned on private on both and now I cannot even see the server when I look at "Network" in the file explorer.

Maybe that makes it simpler? Why can't one PC on a workgroup see the other?


I have a laptop & a file server, both running Windows 10 and both in the same workgroup.

In the explorer on my laptop, when I look at the network, I can see the server but cannot ping it (Destination host unreachable).

I have set a few drives on the server to be shared with full access rights to everyone, but I cannot see them which I click on the server in the explorer, not can I mount them as network drives.

Obviously, I am making some extremely basic mistake - but what?


[Update]
enter image description here Server

C:\Users\me>ipconfig

Windows IP Configuration

Ethernet adapter Ethernet 2:

   Connection-specific DNS Suffix  . : home
   Link-local IPv6 Address . . . . . : fe80::49c6:eb6d:e59d:c62c%6
   IPv4 Address. . . . . . . . . . . : 192.168.1.133
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.254

Tunnel adapter isatap.home:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : home

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fb:1465:1ee5:9266:f153
   Link-local IPv6 Address . . . . . : fe80::1465:1ee5:9266:f153%5
   Default Gateway . . . . . . . . . : ::

Laptop

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . : home
   Link-local IPv6 Address . . . . . : fe80::d951:fafb:b503:f9f2%13
   IPv4 Address. . . . . . . . . . . : 192.168.1.253
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.254

Ethernet adapter Bluetooth Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter isatap.home:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : home

Tunnel adapter Local Area Connection* 5:

   Connection-specific DNS Suffix  . :
   IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fb:448:20aa:9266:f153
   Link-local IPv6 Address . . . . . : fe80::448:20aa:9266:f153%18
   Default Gateway . . . . . . . . . : ::

C:\Users\me>

It is a private network. I presume that is correct (?) Should I be doing anything on the server firewall? enter image description here


[Upper date] I turned off all network sharing on both PCs, then turned on private on both and now I cannot even see the server when I look at "Network" in the file explorer.

Maybe that makes it simpler?

21
  • 1
    what are the IP and firewall settings of both machines? Please post output of ipconfig /all here, and check if windows firewall status
    – Smeerpijp
    Dec 29 '15 at 8:21
  • 1
    Did you check the firewall settings on both machines, your ip settings look fine. Look for the appropriate profile in the network center and check if the firewall is enabled/disabled for that profile, disable if enabled and test again.
    – Smeerpijp
    Dec 29 '15 at 9:58
  • 1
    Make sure both are on the same network as well. In the meantime, were you prompted for credentials when accessing using the IP of the server computer? You'll also need to adjust advance sharing settings through control panel to allow types of sharing.
    – AzkerM
    Dec 29 '15 at 10:25
  • 1
    Disabling IPv6 sometimes helps unsnarl Windows being confused by two competing IP addresses and protocols.
    – harrymc
    Dec 29 '15 at 19:36
  • 1
    @Mawg I don't see that you ever took a print screen of what you get error message wise and attach that to your answer with both the UNC path using IP Address and Server name, etc. as I requested. You say it never prompts but gives some error message. Ping and SMB are two different protocols and two different ports so one not working means nothing for the other really. I assume you DISABLED the FW on both server and client and tried UNC path to the share by IP address and server name both? Please write or add a screen print of the error message that does occur since there is no prompt. Jan 3 '16 at 6:22
2
+25

I had a very similiar issue with remoting arround between my non-windows and my windows machines. What ended up being my problem is one of my windows machines were set to public for the type of connection. As soon as i put it to Workplace or Home all worked well. This is due to network discovery and it sounds like what you are experiencing.

SO, check both to make sure both network location are set to home or work. Choosing Network Location

12
  • 1
    To add to this Windows Network Location awareness effectively has differently defined firewall rulesets for the three different 'network types', domain, private and public. You get a pop up asking what kind of network you are connecting to on first connection. Public networks firewall rule is extremely locked down and may well be the root of your problem here.
    – Patrick
    Dec 29 '15 at 13:31
  • 1
    @mawg windows10 has been kind weird with it. Check here. tinkertry.com/…
    – Tim
    Dec 31 '15 at 15:48
  • 1
    @Mawg Shoot. I did this last night. When i get home i will give it ago again. Just to verify, are the usernames and passwords the same on both devices. If you are not using home-groups, and you have the share set to everyone, you will need to access the share with an account that is on the file server
    – Tim
    Dec 31 '15 at 19:16
  • 1
    So here is what I have done to get mine to work: 1: Verified that both are set to Private 2:Under Advanced Share Settings, I have network disc on, and Turn on auto selected. Under Homegroup Connections i have the 2nd button checked as i do not have the homegroup setup; plus using this method i can access my files from Linux. 3: Verified Share status and network path with appropriate users. After you hit share, go to advanced shareing and set the permissions to everyone.
    – Tim
    Jan 2 '16 at 19:31
  • 1
    @Mawg is the user-account different from the server and from the client? IF yes, try with the server and client having the same username/password
    – Tim
    Jan 4 '16 at 21:54
1

Turn your firewall off and av. See if you can reach it. If not, check your network discovery settings on the PC. If your PC can see it and just can't ping. Could be the ping hits the server but then it's unable to bounce the ping back because there's no return path

1
0

I found 'Windows Networking' extremely frustrating until I adopted this approach:

  • Never assume you have understood what the settings mean
  • Don't change Windows networking settings (if only to avoid feeling like YOU broke it!)
  • Use third-party software for anything with restrictiveness in mind
  • Entirely ignore Workgroups and Homegroups, they are entirely unnecessary to get shares working!

To access a share, you need to actually log in with a user account that exists on the computer doing the sharing. That can be:

  • Same username / password as on your 'usual' computer
  • One Acct everyone uses
  • A tiered system of accounts eg Staff, Managers, public
  • I believe 'Groups' works properly but not using that so cannot recommend

There's a setting like "Let Windows manage logon credentials" to specify one of these for logging on to the network share:

  • Windows uses the username and password you used to log on to the computer you're sitting at (handy!)
  • You have to actually type a username and password the first time you logon that day (only that first time)

but changing it mostly doesn't work! so don't worry if you seem unable to see a change in settings reflected in real-world access behaviour

Rebooting computers one after the other sometimes helps clear out old, failed, attempts at getting shares working.

Hope this helps, it helped me an awful lot!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.