I stumbled across a six pin header on my motherboard designed for an internal Bluetooth module that uses USB protocols to communicate, and ended up making the actual cable that allowed me to place the dongle inside the laptop.

The dongle is http://auspcmarket.com.au/orico-bta-402-bluetooth-4-0-adapter

Now .Windows 10 has some neat new features for integrated Bluetooth modules, like from the action center, and special connection menus for audio devices.

Despite the fact that I'm using the specified Bluetooth module port, Windows 10 doesn't recognize it as a Bluetooth radio, just as another USB device, and I'm stuck with the installed drivers' annoying menus, and a hole in my action center:

enter image description here

enter image description here


3 Answers 3


I'm using a similar bluetooth dongle, from the same brand (Orico BTA-403) and Windows 10.

In my case I had to do this:

1. Turn on Bluetooth Windows Services

Open windows services (run services.msc or search for "services" on windows search).

Change the Bluetooth Handsfree Service and the Bluetooth Support Service to automatic (on properties) and start them.

2. Uninstall the bluetooth driver that comes with the device

When you connect the device, the driver gets installed automatically.

Go to Device Manager (Right click on Start Menu and choose Device Manager or Search for Device Manager).

Find your device on the list. My device was on Universal Serial Bus Devices (I think), named CSR8510 A10.

Right click, choose Uninstall and remember to choose "Delete the driver software for this device" (I tried without this and it did not work).

After that it started to work. You may need to remove the dongle and insert it again or to restart the computer after step 2, but if I recall correctly, it started to work right after step 2 for me.

  • Thanks! This worked for me, the Windows services did not start automatically, uninstalling the drivers that come with it and making sure all the services were started fix it for me!
    – silver
    Mar 12, 2020 at 0:20
  • I had the same issue with Trust Bluetooth ADAPTER Manga. Although, mine was located under "Universal Serial Bus controller" under Devices with a name 'CSR ...'. Right click on the device, check "Delete drivers" and uninstall. Right after that, click on Scan for hardware changes and new device installed! . Apr 23, 2020 at 16:42
  • Setting the services to Automatic and starting them, then disconnecting and reconnecting the adapter worked for me. Note that in my case, the relevant services that I could find and that I started were: Bluetooth support service and Bluetooth Audio Gateway service.
    – alelom
    Sep 20, 2021 at 21:08

This is what I have discovered from experimenting over a long time - for windows GUI Bluetooth features to activate, there cannot be any other installed drivers or interfaces. For me in my case, windows didn't active the features until I had uninstalled the stock drivers (CSR Wireless Stack). Basically, Windows needs to be using the "Generic Bluetooth Radio" drivers for the features to be activated.

So for those looking to make Windows recognize their USB Bluetooth dongles, try uninstalling the drivers.

  • 1
    Make sure to delete the driver software too, or it won't work. Dec 2, 2017 at 14:30
  • Note that uninstalling the driver software needs to be done with proper installation running. I deleted the folder and then uninstalled and it didnt work, need to get the uninstall script do it's work completely and then allow windows to detect.
    – George
    Feb 4, 2019 at 22:11
  • 1. Remove all paired devices (if You have such). 2. Uninstall any Bluetooth software. 3. Follow this instruction answers.microsoft.com/en-us/windows/forum/… and select "Generic Bluetooth Adapter". Jun 8, 2020 at 12:23
  • In compatible devices I see "generic bluetooth radio" and "generic bluetooth adapter", I tried both and they both work. Is there a reason why you picked "radio" over "adapter"?
    – red-o-alf
    May 15, 2021 at 10:44

Asus ZenBook 425EA. The Bluetooth just disappeared suddenly one day, while I was using it.

What worked for me was:

  • Open Device Manager

  • Under Universal Serial Bus Controllers, there was one device with a yellow warning icon, called "Unknown USB Device (Device Descriptor Request Failed)"

  • I did right click > Disabled device, then right click > Enable device

When I did that, the Bluetooth immediately came back online.

It might be related to the laptop going into hibernate mode.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .